summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 03:30:51 -0600
committerBrian Bidulock2015-06-10 03:30:51 -0600
commit6d91f295be36d5db7199b0398073b9abd7314a4e (patch)
treeff7207df516d5e15873da7b809fe5542f7eaa870
downloadaur-6d91f295be36d5db7199b0398073b9abd7314a4e.tar.gz
initial version
-rw-r--r--.SRCINFO24
-rw-r--r--2bwm.copying14
-rw-r--r--2bwm.desktop6
-rw-r--r--PKGBUILD26
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b4192bdda76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = 2bwm
+ pkgdesc = A fast floating window manager
+ pkgver = 0.2
+ pkgrel = 2
+ url = https://github.com/venam/2bwm
+ arch = i686
+ arch = x86_64
+ license = ISC
+ makedepends = git
+ makedepends = xcb-util
+ depends = xcb-util-wm
+ depends = xcb-util-keysyms
+ conflicts = 2bwm-git
+ conflicts = mcwm
+ conflicts = mcwm-git
+ source = 2bwm::git+https://github.com/bbidulock/2bwm.git#tag=v0.2
+ source = 2bwm.desktop
+ source = 2bwm.copying
+ md5sums = SKIP
+ md5sums = 4342d9210effbe4bfb58722f4275aa5c
+ md5sums = adaee5c7e455ba15e0ca9a2692464253
+
+pkgname = 2bwm
+
diff --git a/2bwm.copying b/2bwm.copying
new file mode 100644
index 000000000000..c4d323d911df
--- /dev/null
+++ b/2bwm.copying
@@ -0,0 +1,14 @@
+Copyright (c) 2010, 2011, 2012 Michael Cardell Widerkrantz, mc at the domain hack.org.
+Copyright (c) 2013 Patrick Louis and Youri Mouton, patrick or beastie at the domain unixhub.net.
+
+Permission to use, copy, modify, and distribute this software for any
+purpose with or without fee is hereby granted, provided that the above
+copyright notice and this permission notice appear in all copies.
+
+THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/2bwm.desktop b/2bwm.desktop
new file mode 100644
index 000000000000..f75061a131aa
--- /dev/null
+++ b/2bwm.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=2bwm
+Comment=2bwm - A fast floating and keyboard driven window manager
+Exec=2bwm
+Type=XSession
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9b97d511f15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+pkgname='2bwm'
+pkgver=0.2
+pkgrel=2
+pkgdesc="A fast floating window manager"
+arch=('i686' 'x86_64')
+url="https://github.com/venam/2bwm"
+license=('ISC')
+depends=('xcb-util-wm' 'xcb-util-keysyms')
+conflicts=('2bwm-git' 'mcwm' 'mcwm-git') # due to /usr/bin/hidden program
+makedepends=('git' 'xcb-util')
+source=("$pkgname::git+https://github.com/bbidulock/2bwm.git#tag=v0.2" '2bwm.desktop' '2bwm.copying')
+md5sums=('SKIP'
+ '4342d9210effbe4bfb58722f4275aa5c'
+ 'adaee5c7e455ba15e0ca9a2692464253')
+
+build() {
+ cd $pkgname
+ make PREFIX=/usr
+}
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" PREFIX=/usr MANPREFIX=/usr/share/man install
+ install -Dm644 "$srcdir/2bwm.desktop" "$pkgdir/usr/share/xsessions/2bwm.desktop"
+ install -Dm644 "$srcdir/2bwm.copying" "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}