summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoron Behar2018-01-12 17:52:06 +0200
committerDoron Behar2018-01-12 17:52:06 +0200
commit97557f699cb64d9acef0dddd75084e59b4214ebe (patch)
tree8cc49931ca6e5d89f442af226e44fd1b638e76df
downloadaur-97557f699cb64d9acef0dddd75084e59b4214ebe.tar.gz
Initial commit.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3aa8f771b1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = 2fa
+ pkgdesc = Two factor authentication agent
+ pkgver = 1.1.0
+ pkgrel = 1
+ arch = x86_64
+ license = BSD
+ makedepends = go
+ depends = glibc
+ conflicts = 2fa-git
+ replaces = 2fa-git
+ source = https://github.com/rsc/2fa/archive/v1.1.0.tar.gz
+ sha256sums = ecd5ba067d3e3bbc3f8c10fa2df01b1b388b1cd6503fb56381573d8d17497755
+
+pkgname = 2fa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f324baa54ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Doron Behar <doron.behar@gmail.com>
+
+pkgname=2fa
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Two factor authentication agent"
+arch=('x86_64')
+license=('BSD')
+depends=('glibc')
+makedepends=('go')
+conflicts=('2fa-git')
+replaces=('2fa-git')
+source=("https://github.com/rsc/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('ecd5ba067d3e3bbc3f8c10fa2df01b1b388b1cd6503fb56381573d8d17497755')
+
+build() {
+ cd "$pkgname-$pkgver"
+ GOPATH=`pwd` go get -d -v
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ GOPATH=`pwd` go build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 ${pkgname}-${pkgver} "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: