summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeoTheFox2016-02-24 19:21:20 +0100
committerNeoTheFox2016-02-24 19:21:20 +0100
commitc313abc8cee4fc590b695b22f2a2515972c0f017 (patch)
tree3db28c58812b06325617c3ae0bb63dff6907e80f
downloadaur-c313abc8cee4fc590b695b22f2a2515972c0f017.tar.gz
initial
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD28
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc679b2e9356
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed Feb 24 18:20:44 UTC 2016
+pkgbase = 3delta-git
+ pkgdesc = Host software especially suited for delta 3d printers
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/minad/3delta
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = tk
+ depends = tcllib
+ depends = tcl
+ depends = tklib
+ provides = 3delta
+ conflicts = 3delta
+ source = 3delta-git::https://github.com/minad/3delta.git
+ md5sums = SKIP
+
+pkgname = 3delta-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65725677233e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=3delta-git
+pkgver=1
+pkgrel=1
+pkgdesc="Host software especially suited for delta 3d printers"
+arch=('i686' 'x86_64')
+url="https://github.com/minad/3delta"
+license=('GPL')
+depends=('tk' 'tcllib' 'tcl' 'tklib')
+makedepends=('git')
+conflicts=('3delta')
+provides=('3delta')
+# The git repo is detected by the 'git:' or 'git+' beginning. The branch
+# '$pkgname' is then checked out upon cloning, expediating versioning:
+#source=('git+https://github.com/falconindy/expac.git'
+source=("$pkgname"::'https://github.com/minad/3delta.git')
+# Because the sources are not static, skip Git checksum:
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ # Use the tag of the last commit
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 "3delta" "$pkgdir/usr/bin/3delta"
+}