summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorheinrich59912015-08-18 03:01:09 +0200
committerheinrich59912015-08-18 03:02:10 +0200
commit29a706d9e8de14073cedad5b32489c4dcadcb1a7 (patch)
tree8bfba78ea6d0acf5c6f9bf8d1db608c93ddf5eee
downloadaur-29a706d9e8de14073cedad5b32489c4dcadcb1a7.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rwxr-xr-x3dgame14
-rw-r--r--PKGBUILD34
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fda496106fd8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = 3dgame-git
+ pkgdesc = A voxel game proof-of-concept
+ pkgver = 20150818
+ pkgrel = 1
+ url = https://github.com/speedy-consoles/3dgamecpp
+ arch = x86
+ arch = x86_64
+ license = none
+ depends = boost-libs
+ depends = ftgl
+ depends = glew
+ depends = glu
+ depends = libgl
+ depends = log4cxx
+ depends = sdl2
+ depends = sdl2_image
+ source = git://github.com/speedy-consoles/3dgamecpp
+ source = 3dgame
+ sha256sums = SKIP
+ sha256sums = 7ff10ee8a254e8c69f17e26b73749721d9a81f5081c6163c2ae8dcf5858d2997
+
+pkgname = 3dgame-git
+
diff --git a/3dgame b/3dgame
new file mode 100755
index 000000000000..5826ae1c2fc9
--- /dev/null
+++ b/3dgame
@@ -0,0 +1,14 @@
+#!/usr/bin/env bash
+set -o errexit
+set -o pipefail
+set -o nounset
+
+cd /usr/share/3dgame/
+mkdir -p ~/.config/3dgame/
+for file in *; do
+ if [ ! -e ~/.config/3dgame/"$file" ]; then
+ ln -s /usr/share/3dgame/"$file" ~/.config/3dgame/"$file"
+ fi
+done
+cd ~/.config/3dgame/
+/usr/lib/3dgame/3dgame
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6965515f4b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: heinrich5991 <heinrich5991@gmail.com>
+pkgname=3dgame-git
+pkgver=20150818
+pkgrel=1
+pkgdesc="A voxel game proof-of-concept"
+arch=('x86' 'x86_64')
+url="https://github.com/speedy-consoles/3dgamecpp"
+license=('none')
+depends=('boost-libs'
+ 'ftgl'
+ 'glew'
+ 'glu'
+ 'libgl'
+ 'log4cxx'
+ 'sdl2'
+ 'sdl2_image')
+source=('git://github.com/speedy-consoles/3dgamecpp'
+ '3dgame')
+sha256sums=('SKIP'
+ '7ff10ee8a254e8c69f17e26b73749721d9a81f5081c6163c2ae8dcf5858d2997')
+
+build() {
+ cd "$srcdir"/3dgamecpp/
+ make DEBUG=0
+}
+
+package() {
+ cd "$srcdir"/3dgamecpp/
+ install -dm755 "$pkgdir"/usr/{lib,share}/3dgame/ "$pkgdir"/usr/bin/
+
+ cp -r *.txt *.conf fonts/ img/ res/ shaders/ "$pkgdir"/usr/share/3dgame/
+ install -m755 bin/release/3dgame "$pkgdir"/usr/lib/3dgame/
+ install -m755 ../3dgame "$pkgdir"/usr/bin/
+}