summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Koller-Cherek2019-12-26 20:59:52 +0100
committerThomas Koller-Cherek2019-12-26 20:59:52 +0100
commitbf493924ee10127f327d41a1593932934e2f96dd (patch)
tree388a4849ef4b5f2fd90cc0cf3da89fa50a6e0763
parentdf5f6833f869a50f480011712c4d10619754edaf (diff)
downloadaur-bf493924ee10127f327d41a1593932934e2f96dd.tar.gz
Release r117.383fc1c-1
-rw-r--r--PKGBUILD26
1 files changed, 9 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd87ee79da50..45adb4cf1961 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,23 @@
# Maintainer: yubimusubi
+# Current Maintainer: Thomas Koller-Cherek <tk120 at protonmail dot com>
+
pkgname=('3dsconv-git')
provides=('3dsconv')
conflicts=('3dsconv')
-pkgver=r83.00a95c3
+pkgver=r117.383fc1c
pkgrel=1
pkgdesc='Tool to convert Nintendo 3DS CTR Cart Image files (CCI, ".3ds") to the CTR Importable Archive format (CIA).'
arch=('any')
url="https://github.com/ihaveamac/3dsconv"
license=('MIT')
-depends=('python2')
-makedepends=('git' 'tar')
+depends=('python' 'python-pyaes')
+makedepends=('git')
options=('!strip')
-optdepends=('python2-crypto: support for zerokey-encryption')
-
-source=(
- "$pkgname::git+https://github.com/ihaveamac/3dsconv.git"
-)
-
+optdepends=('python-crypto: support for zerokey-encryption')
+source=("git+https://github.com/ihaveamac/3dsconv.git")
sha256sums=('SKIP')
-pkgver() {
- cd "$pkgname"
- echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
-}
-
package() {
- cd "$pkgname"
install -d "$pkgdir/usr/bin/"
- install "3dsconv.py" "$pkgdir/usr/bin/3dsconv"
-}
+ install "3dsconv/3dsconv/3dsconv.py" "$pkgdir/usr/bin/3dsconv"
+}