summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoosted72018-07-14 10:58:22 +0200
committerRoosted72018-07-14 10:58:22 +0200
commit94122454bf34884e95e9cecfc659d23e882c0ab9 (patch)
tree7a1bc3f4e05b382adb2982df589f864b42c9286d
downloadaur-94122454bf34884e95e9cecfc659d23e882c0ab9.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--3dslicer.desktop10
-rw-r--r--PKGBUILD29
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f21a70d0d2b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = 3dslicer-nightly
+ pkgdesc = A free, open source software package for image analysis and scientific visualization.
+ pkgver = 4.9.0_2018_07_13
+ pkgrel = 1
+ url = http://slicer.org
+ arch = x86_64
+ license = BSD
+ depends = glu
+ provides = 3dslicer
+ conflicts = 3dslicer
+ source = Slicer-4.9.0-2018-07-13-linux-amd64.tar.gz::http://download.slicer.org/bitstream/839500
+ source = 3dslicer.png::https://www.slicer.org/slicerWiki/images/7/71/3DSlicerLogo-DesktopIcon-128x128.png
+ source = 3dslicer.desktop
+ sha512sums = 27a35df50772a2b1e23a19aa11cc8ed9b0e5febaea6db209131d30d2636ca2e10854d872bb58408df61340bef1228b51615f01fd4c3a5a18ba2b69660b3855a4
+ sha512sums = f3f8a3de8b774d2a968e293471f92d23af5f56a2f025f0ad49035802d94f35a6578c8a161e9f9ed3c2f63beb337bea6952f93e0651ecc6a34c20fd8171e4d087
+ sha512sums = 0a6c00eeb4bac3862c0cac63b20d05068deb2f46540ba5f73bad9f74697d62022b952641562762049fb0473eed9cd816e39388c440fbdef03518609825834194
+
+pkgname = 3dslicer-nightly
+
diff --git a/3dslicer.desktop b/3dslicer.desktop
new file mode 100644
index 000000000000..afb09271c607
--- /dev/null
+++ b/3dslicer.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=3D Slicer
+Comment=Start 3D Slicer
+Exec=Slicer
+Type=Application
+Icon=3dslicer.png
+StartupNotify=true
+Categories=Graphics;MedicalSoftware;Science;
+X-Desktop-File-Install-Version=
+MimeType=
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1194c5a997d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Thomas Roos (Roosted7) <mail [at] thomasroos [dot] nl>
+
+# Thanks and credits to Chris (crmullins) for the stable version of this PKGBUILD, which formed the basis of this version
+
+pkgname=3dslicer-nightly
+pkgver=4.9.0_2018_07_13
+pkgrel=1
+pkgdesc="A free, open source software package for image analysis and scientific visualization."
+url="http://slicer.org"
+arch=('x86_64')
+license=('BSD')
+depends=('glu')
+conflicts=('3dslicer')
+provides=('3dslicer')
+source=("Slicer-${pkgver//_/-}-linux-amd64.tar.gz::http://download.slicer.org/bitstream/839500"
+ "3dslicer.png::https://www.slicer.org/slicerWiki/images/7/71/3DSlicerLogo-DesktopIcon-128x128.png"
+ "3dslicer.desktop")
+sha512sums=('27a35df50772a2b1e23a19aa11cc8ed9b0e5febaea6db209131d30d2636ca2e10854d872bb58408df61340bef1228b51615f01fd4c3a5a18ba2b69660b3855a4'
+ 'f3f8a3de8b774d2a968e293471f92d23af5f56a2f025f0ad49035802d94f35a6578c8a161e9f9ed3c2f63beb337bea6952f93e0651ecc6a34c20fd8171e4d087'
+ '0a6c00eeb4bac3862c0cac63b20d05068deb2f46540ba5f73bad9f74697d62022b952641562762049fb0473eed9cd816e39388c440fbdef03518609825834194')
+
+package() {
+ install -d "$pkgdir"/opt/3dslicer "$pkgdir"/usr/bin
+ mv "$srcdir/Slicer-${pkgver//_/-}-linux-amd64/"* "$pkgdir/opt/3dslicer"
+ ln -s /opt/3dslicer/Slicer "$pkgdir/usr/bin"
+ install -Dm644 "${srcdir}/3dslicer.desktop" "${pkgdir}/usr/share/applications/3dslicer.desktop"
+ # https://www.slicer.org/slicerWiki/index.php/Slicer3:Slicer3Brand
+ install -Dm644 "${srcdir}/3dslicer.png" "${pkgdir}/usr/share/pixmaps/3dslicer.png"
+}