summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2019-03-11 16:16:36 +0100
committerMaxime Gauduin2019-03-11 16:16:36 +0100
commit1d43256fb97633c60d3b429fa375736ac223c7a9 (patch)
treee05dab196ab04fb93a9477dd457c2ab9c120b59e
parent5c3ebe23086dbc0c0e3698e9f1c339e82bbc9d5b (diff)
downloadaur-1d43256fb97633c60d3b429fa375736ac223c7a9.tar.gz
bump 3dstool
-rw-r--r--.SRCINFO19
-rw-r--r--3dstool-openssl1.0.patch13
-rw-r--r--PKGBUILD52
3 files changed, 35 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7cfb0b91160b..6b48c35f5a96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,20 @@
# Generated by mksrcinfo v8
-# Wed Oct 11 21:08:54 UTC 2017
+# Mon Mar 11 15:16:36 UTC 2019
pkgbase = 3dstool
pkgdesc = An all-in-one tool for extracting/creating 3ds roms
- pkgver = 1.0.27
+ pkgver = 1.2.3
pkgrel = 1
url = https://github.com/dnasdw/3dstool
- arch = i686
arch = x86_64
- license = None
+ license = MIT
makedepends = cmake
- depends = curl
- depends = glibc
- depends = openssl-1.0
- source = 3dstool-1.0.27.tar.gz::https://github.com/dnasdw/3dstool/archive/v1.0.27.tar.gz
+ makedepends = git
+ depends = libcurl.so
+ depends = openssl
+ source = git+https://github.com/dnasdw/3dstool.git#tag=v1.2.3
source = 3dstool-paths.patch
- source = 3dstool-openssl1.0.patch
- sha256sums = face9b645ddcf644dc01b1e045261fd9dc761089cf48d54fd12483265a7cd79d
+ sha256sums = SKIP
sha256sums = 5ac00e5b56182ffde04c7b9ab2a5151e6cf575400705f0b061ff832116757582
- sha256sums = f6099fde2c1cee1bba111ee112991f475ce29a56b55a17255d80f813dc2f598c
pkgname = 3dstool
diff --git a/3dstool-openssl1.0.patch b/3dstool-openssl1.0.patch
deleted file mode 100644
index 2ccebab041c1..000000000000
--- a/3dstool-openssl1.0.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -rupN 3dstool-1.0.25.orig/CMakeLists.txt 3dstool-1.0.25/CMakeLists.txt
---- 3dstool-1.0.25.orig/CMakeLists.txt 2017-06-20 00:21:12.997972908 +0200
-+++ 3dstool-1.0.25/CMakeLists.txt 2017-06-20 00:31:21.511945922 +0200
-@@ -41,6 +41,9 @@ include(AutoFiles)
- if(USE_DEP)
- ADD_DEP_INCLUDE_DIR("${ROOT_SOURCE_DIR}/dep")
- ADD_DEP_LIBRARY_DIR("${ROOT_SOURCE_DIR}/dep")
-+else()
-+ ADD_DEP_INCLUDE_DIR("/usr/include/openssl-1.0")
-+ ADD_DEP_LIBRARY_DIR("/usr/lib/openssl-1.0")
- endif()
- if(UNIX OR MINGW)
- if(CYGWIN)
diff --git a/PKGBUILD b/PKGBUILD
index 624178fe9cfb..f756560a172f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,49 +2,51 @@
# Contributor: yubimusubi <possum+aur@possum.cc>
pkgname=3dstool
-pkgver=1.0.27
+pkgver=1.2.3
pkgrel=1
pkgdesc='An all-in-one tool for extracting/creating 3ds roms'
-arch=('i686' 'x86_64')
-url='https://github.com/dnasdw/3dstool'
-license=('None')
-depends=('curl' 'glibc' 'openssl-1.0')
-makedepends=('cmake')
-source=("3dstool-${pkgver}.tar.gz::https://github.com/dnasdw/3dstool/archive/v${pkgver}.tar.gz"
- '3dstool-paths.patch'
- '3dstool-openssl1.0.patch')
-sha256sums=('face9b645ddcf644dc01b1e045261fd9dc761089cf48d54fd12483265a7cd79d'
- '5ac00e5b56182ffde04c7b9ab2a5151e6cf575400705f0b061ff832116757582'
- 'f6099fde2c1cee1bba111ee112991f475ce29a56b55a17255d80f813dc2f598c')
+arch=(x86_64)
+url=https://github.com/dnasdw/3dstool
+license=(MIT)
+depends=(
+ libcurl.so
+ openssl
+)
+makedepends=(
+ cmake
+ git
+)
+source=(
+ git+https://github.com/dnasdw/3dstool.git#tag=v${pkgver}
+ 3dstool-paths.patch
+)
+sha256sums=('SKIP'
+ '5ac00e5b56182ffde04c7b9ab2a5151e6cf575400705f0b061ff832116757582')
prepare() {
- cd 3dstool-${pkgver}
-
if [[ -d build ]]; then
rm -rf build
fi
mkdir build
+ cd 3dstool
+
patch -Np1 -i ../3dstool-paths.patch
- patch -Np1 -i ../3dstool-openssl1.0.patch
}
build() {
- cd 3dstool-${pkgver}/build
+ cd build
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DUSE_DEP='OFF'
+ cmake ../3dstool \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DUSE_DEP=OFF
make
}
package() {
- cd 3dstool-${pkgver}/build
-
- make install
-
- install -Dm 755 ../bin/3dstool -t "${pkgdir}"/usr/bin/
- install -Dm 644 ../bin/ignore_3dstool.txt -t "${pkgdir}"/usr/share/3dstool/
+ make -C build install
+ install -Dm 755 3dstool/bin/3dstool -t "${pkgdir}"/usr/bin/
+ install -Dm 644 3dstool/bin/ignore_3dstool.txt -t "${pkgdir}"/usr/share/3dstool/
}
# vim: ts=2 sw=2 et: