summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Kotta2017-08-18 13:26:35 -0500
committerJonathan Kotta2017-08-18 13:26:35 -0500
commit3ad2fb38778a562ad579ca21383e6e6556732c1c (patch)
treeb545b1e3c452e1eb21de42ca3b90fe8dfec60489
parentd2edece1ba71d1978371f1aef7d9f2d8452c27c6 (diff)
downloadaur-3ad2fb38778a562ad579ca21383e6e6556732c1c.tar.gz
bump version and use pypi URL
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index edf1d61adf9b..e84370b528cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = 3to2
pkgdesc = Script to convert python3 code to python2. Counterpart to 2to3
- pkgver = 1.0
- pkgrel = 4
- url = https://bitbucket.org/amentajo/lib3to2
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/3to2
arch = any
license = Apache
- makedepends = mercurial
- depends = python2
- source = https://bitbucket.org/amentajo/lib3to2/downloads/3to2-1.0.tar.gz
- md5sums = c23a3841fdd5ca0493533c74d6c4de5c
+ depends = python
+ source = https://pypi.python.org/packages/8f/ab/58a363eca982c40e9ee5a7ca439e8ffc5243dde2ae660ba1ffdd4868026b/3to2-1.1.1.zip
+ md5sums = cbeed28e350dbdaef86111ace3052824
pkgname = 3to2
diff --git a/PKGBUILD b/PKGBUILD
index 43400951938e..e9c9ec85981f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
-# Maintainer: Andreas Theodosiou <andreasabu at gmail dot com>
+# Maintainer: Jonathan Kotta <jpkotta at gmail dot com>
+# Contributor: Andreas Theodosiou <andreasabu at gmail dot com>
# Contributor: Jarek Sedlacek <jareksedlacek at gmail dot com>
pkgname=3to2
-pkgver=1.0
-pkgrel=4
+pkgver=1.1.1
+pkgrel=1
pkgdesc="Script to convert python3 code to python2. Counterpart to 2to3"
arch=('any')
license=('Apache')
-url='https://bitbucket.org/amentajo/lib3to2'
-depends=('python2')
-makedepends=('mercurial')
-source=("https://bitbucket.org/amentajo/lib3to2/downloads/3to2-$pkgver.tar.gz")
-noextract=()
-md5sums=('c23a3841fdd5ca0493533c74d6c4de5c')
-
-
+url='https://pypi.python.org/pypi/3to2'
+depends=('python')
+makedepends=()
+# files.pythonhosted.org URL as suggested by Arch Wiki doesn't work
+source=('https://pypi.python.org/packages/8f/ab/58a363eca982c40e9ee5a7ca439e8ffc5243dde2ae660ba1ffdd4868026b/3to2-1.1.1.zip')
+md5sums=('cbeed28e350dbdaef86111ace3052824')
package() {
- cd "$srcdir/$pkgname-$pkgver"
- ./setup.py install --root=$pkgdir/ --optimize=1
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python ./setup.py install --root="${pkgdir}" --optimize=1
+ rm -rf "${pkgdir}"/usr/lib/python*/site-packages/lib3to2/tests/
}