summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Zálešák2016-07-19 17:09:33 +0200
committerDavid Zálešák2016-07-19 17:09:33 +0200
commitdec0c171b1c5b69e2e0da7e43266e144e6904597 (patch)
tree195a41c75eebb7fb581306dceb5b14efdc7edc84
downloadaur-dec0c171b1c5b69e2e0da7e43266e144e6904597.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--4chan-downloader3
-rw-r--r--4chan-downloader.desktop7
-rw-r--r--PKGBUILD47
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..848245101abe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = 4chan-downloader
+ pkgdesc = A tool to download images from 4chan, 2chan and more!
+ pkgver = 1.7.0
+ pkgrel = 1
+ url = http://sourceforge.net/projects/fourchan-dl/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = qt4
+ source = http://sourceforge.net/projects/fourchan-dl/files/v1.7.0/fourchan-dl-src-v1.7.0.zip
+ source = 4chan-downloader
+ source = 4chan-downloader.desktop
+ md5sums = 4f517439357a46ee9e1ac31a6a86a459
+ md5sums = a36be476ed2702a5cee6305a58a795e0
+ md5sums = 54184e14df4d5da32e10e2be19100c87
+
+pkgname = 4chan-downloader
+
diff --git a/4chan-downloader b/4chan-downloader
new file mode 100644
index 000000000000..81a84110e5b0
--- /dev/null
+++ b/4chan-downloader
@@ -0,0 +1,3 @@
+#!/bin/bash
+cd /usr/share/4chan-downloader
+./fourchan-dl
diff --git a/4chan-downloader.desktop b/4chan-downloader.desktop
new file mode 100644
index 000000000000..5155e24f927f
--- /dev/null
+++ b/4chan-downloader.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=4chan-downloader
+Icon=/usr/share/pixmaps/4chan-downloader.png
+Exec=4chan-downloader
+Terminal=false
+Categories=Graphics;Network
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef31fa0de877
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: archtux <antonio dot arias99999 at gmail dot com>
+
+pkgname=4chan-downloader
+pkgver=1.7.0
+pkgrel=1
+pkgdesc="A tool to download images from 4chan, 2chan and more!"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/fourchan-dl/"
+license=('GPL3')
+depends=('qt4')
+source=(http://sourceforge.net/projects/fourchan-dl/files/v$pkgver/fourchan-dl-src-v$pkgver.zip
+ $pkgname
+ $pkgname.desktop)
+md5sums=('4f517439357a46ee9e1ac31a6a86a459'
+ 'a36be476ed2702a5cee6305a58a795e0'
+ '54184e14df4d5da32e10e2be19100c87')
+
+prepare() {
+ cd $srcdir
+ qmake-qt4
+}
+
+build() {
+ cd $srcdir
+ make
+}
+
+package() {
+ cd $srcdir
+ # Binaries
+ install -Dm755 fourchan-dl $pkgdir/usr/share/4chan-downloader/fourchan-dl
+ install -Dm755 fourchan-dl-console $pkgdir/usr/share/4chan-downloader/fourchan-dl-console
+
+ # Plugins
+ mkdir -p $pkgdir/usr/share/4chan-downloader/plugins
+ cp plugins/*.so $pkgdir/usr/share/4chan-downloader/plugins
+
+ # Start file
+ install -Dm755 $pkgname $pkgdir/usr/bin/$pkgname
+
+ # Desktop icon
+ install -Dm644 gui/resources/4chan.png $pkgdir/usr/share/pixmaps/$pkgname.png
+ install -Dm644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+
+ # Make directory writeable
+ chmod o+w $pkgdir/usr/share/4chan-downloader
+}