summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:16 +0200
committerMuflone2015-06-13 17:59:16 +0200
commitd2dc91f49158420e4ba588caa1b028fcf9b25fb2 (patch)
tree03dc23ce3d82d888274b16b0397477633a1d0e3a
downloadaur-d2dc91f49158420e4ba588caa1b028fcf9b25fb2.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--4kvideodownloader.desktop11
-rw-r--r--4kvideodownloader.pngbin0 -> 6828 bytes
-rw-r--r--PKGBUILD25
4 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03611189ed35
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = 4kvideodownloader
+ pkgdesc = Quickly download videos from YouTube in high-quality.
+ pkgver = 3.5.5.1700
+ pkgrel = 1
+ url = http://www.4kdownload.com/products/product-videodownloader
+ arch = i686
+ arch = x86_64
+ license = custom:eula
+ depends = qt5-script
+ depends = portaudio
+ depends = ffmpeg-compat
+ depends = ffmpeg-compat-55>=2.3.4-2
+ source = 4kvideodownloader.desktop
+ source = 4kvideodownloader.png
+ sha256sums = 6ab39088bde330267b43f87878f6bd47a215c732e17d417a99fc23ac4c568952
+ sha256sums = 56b851ef96aade0612f236b8763ccaf2def8acdd49f37bbefdd79e1d5f6e68be
+ source_i686 = http://downloads.4kdownload.com/app/4kvideodownloader_3.5_i386.tar.bz2
+ sha256sums_i686 = f8dfccba34970f2ac439ea80b58a31d87a1b55c544872930d53bc1547907b46b
+ source_x86_64 = http://downloads.4kdownload.com/app/4kvideodownloader_3.5_amd64.tar.bz2
+ sha256sums_x86_64 = be635c525552b0c1dfe2db5b65a78b24d54dbb2d37e5b68f2f36886658fc7284
+
+pkgname = 4kvideodownloader
+
diff --git a/4kvideodownloader.desktop b/4kvideodownloader.desktop
new file mode 100644
index 000000000000..392c964ed0a9
--- /dev/null
+++ b/4kvideodownloader.desktop
@@ -0,0 +1,11 @@
+
+[Desktop Entry]
+Name=4K Video Downloader
+GenericName=4K Video Downloader
+Comment=Download online video
+Exec=4kvideodownloader
+Terminal=false
+Type=Application
+Icon=4kvideodownloader.png
+Categories=Network;Qt;
+
diff --git a/4kvideodownloader.png b/4kvideodownloader.png
new file mode 100644
index 000000000000..4529c03f5243
--- /dev/null
+++ b/4kvideodownloader.png
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc3e953d9b36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
+pkgname=4kvideodownloader
+pkgver=3.5.5.1700
+pkgrel=1
+pkgdesc="Quickly download videos from YouTube in high-quality."
+arch=('i686' 'x86_64')
+url="http://www.4kdownload.com/products/product-videodownloader"
+license=('custom:eula')
+depends=('qt5-script' 'portaudio' 'ffmpeg-compat' 'ffmpeg-compat-55>=2.3.4-2')
+source=("${pkgname}.desktop"
+ "${pkgname}.png")
+source_i686=("http://downloads.4kdownload.com/app/${pkgname}_${pkgver%.*.*}_i386.tar.bz2")
+source_x86_64=("http://downloads.4kdownload.com/app/${pkgname}_${pkgver%.*.*}_amd64.tar.bz2")
+sha256sums=('6ab39088bde330267b43f87878f6bd47a215c732e17d417a99fc23ac4c568952'
+ '56b851ef96aade0612f236b8763ccaf2def8acdd49f37bbefdd79e1d5f6e68be')
+sha256sums_i686=('f8dfccba34970f2ac439ea80b58a31d87a1b55c544872930d53bc1547907b46b')
+sha256sums_x86_64=('be635c525552b0c1dfe2db5b65a78b24d54dbb2d37e5b68f2f36886658fc7284')
+
+package() {
+ install -m 755 -D "${srcdir}/${pkgname}/${pkgname}-bin" "${pkgdir}/usr/bin/${pkgname}"
+ install -m 644 -D "${srcdir}/${pkgname}/doc/eula" "${pkgdir}/usr/share/licenses/${pkgname}/eula"
+ install -m 755 -D "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -m 755 -D "${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+}