summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgiga3002019-07-01 11:39:46 +0200
committergiga3002019-07-01 11:39:46 +0200
commit6635803746ff9f50ec8e871d72fe1cde2220e377 (patch)
tree4b30f684868fdfbfbd6334b1095da19eb669349a
downloadaur-6635803746ff9f50ec8e871d72fe1cde2220e377.tar.gz
Init package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..405ce6a3bf97
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = 4nxci-git
+ pkgdesc = 4NXCI is a tool for converting XCI(NX Card Image) files to NSP
+ pkgver = v4.03.r2.g33044e6
+ pkgrel = 1
+ url = https://github.com/The-4n/4NXCI
+ arch = any
+ license = ISC
+ makedepends = git
+ depends = glibc
+ provides = 4nxci-bin
+ conflicts = 4nxci-bin
+ source = git+https://github.com/The-4n/4NXCI.git
+ sha256sums = SKIP
+
+pkgname = 4nxci-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8be366b7466a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: giga300 <giga300[at]protonmail[dot]com>
+# Maintainer: giga300 <giga300[at]protonmail[dot]com>
+
+pkgname=4nxci-git
+_pkgname=4NXCI
+pkgver=v4.03.r2.g33044e6
+pkgrel=1
+pkgdesc='4NXCI is a tool for converting XCI(NX Card Image) files to NSP'
+arch=('any')
+url="https://github.com/The-4n/4NXCI"
+license=('ISC')
+depends=('glibc')
+makedepends=('git')
+provides=("4nxci-bin")
+conflicts=("4nxci-bin")
+source=('git+https://github.com/The-4n/4NXCI.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ cp config.mk.template config.mk
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ install -Dm755 "$srcdir/${_pkgname}/${pkgname%-git}" "$pkgdir/usr/bin/${pkgname%-git}"
+} \ No newline at end of file