summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hesse2021-10-29 18:32:04 +0200
committerTom Hesse2021-10-29 18:32:04 +0200
commit4a419f836648a455a9ed010a4c562ae1b31df351 (patch)
tree1d66f6e1e54da9baa0190dafe1911b48260c1d64
downloadaur-4a419f836648a455a9ed010a4c562ae1b31df351.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--4scanner.install10
-rw-r--r--PKGBUILD29
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7a6ca7a6726
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = 4scanner
+ pkgdesc = Command line tool to download images from multiple imageboards
+ pkgver = 1.6.2
+ pkgrel = 1
+ url = https://github.com/pboardman/4scanner/
+ install = 4scanner.install
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python3
+ depends = python-requests>=2.20
+ source = 4scanner-1.6.2.tar.gz::https://github.com/pboardman/4scanner/archive/refs/tags/1.6.2.tar.gz
+ sha256sums = dc7470615353b137a0af4732b995428c5e794e4b85aeb70f84ba76e2f86224b1
+
+pkgname = 4scanner
diff --git a/4scanner.install b/4scanner.install
new file mode 100644
index 000000000000..4ffda5dd83ae
--- /dev/null
+++ b/4scanner.install
@@ -0,0 +1,10 @@
+post_install() {
+ cat << EOF
+ You need to create a json file with the directory names,
+ the boards you want to search and the keywords.
+ You can either use the 4genconf command or create the
+ file manually. An example is under /usr/share/doc/4scanner/example.json.
+ Under /usr/share/doc/4scanner/4scanner.service you will
+ also find a systemd unit file.
+EOF
+}
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f46599113e70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Tom Hesse <heyhoman at mailbox dot org>
+pkgname=4scanner
+pkgver=1.6.2
+pkgrel=1
+pkgdesc="Command line tool to download images from multiple imageboards"
+arch=('any')
+url="https://github.com/pboardman/4scanner/"
+license=('MIT')
+depends=('python3' 'python-requests>=2.20')
+makedepends=('python-setuptools')
+install=4scanner.install
+source=($pkgname-$pkgver.tar.gz::https://github.com/pboardman/4scanner/archive/refs/tags/$pkgver.tar.gz)
+sha256sums=('dc7470615353b137a0af4732b995428c5e794e4b85aeb70f84ba76e2f86224b1')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py clean --all
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README"
+ install -Dm644 OPTIONS.md "$pkgdir/usr/share/doc/$pkgname/OPTIONS"
+ install -Dm644 example.json "$pkgdir/usr/share/doc/$pkgname/example.json"
+ install -Dm644 contrib/systemd/4scanner.service "$pkgdir/usr/share/doc/$pkgname/4scanner.service"
+ python setup.py install --root "$pkgdir" --skip-build
+}