summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2015-05-30 20:06:36 +0200
committerNarrat2015-06-08 17:01:49 +0200
commitff4135f95c93e9704e3a535d3882fe822fa60ffc (patch)
tree36497b154cec6b0255a0deae0d67364636289a66
downloadaur-ff4135f95c93e9704e3a535d3882fe822fa60ffc.tar.gz
555-boom: Latest files
For the history see http://pkgbuild.com/git/aur-mirror.git/log/555-boom https://github.com/Narrat/PKGBuilds https://gitlab.com/Narrat/PKGBuilds
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore14
-rw-r--r--555-boom.desktop11
-rw-r--r--PKGBUILD34
4 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6225ae6edde5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = 555-boom
+ pkgdesc = Puzzle Game and Electromechanical Sandbox
+ pkgver = 0.6.1
+ pkgrel = 4
+ url = http://www.cosc.canterbury.ac.nz/greg.ewing/python/PyWeek5/index.html
+ arch = any
+ license = GPL
+ depends = python2-pygame
+ source = http://www.cosc.canterbury.ac.nz/greg.ewing/python/PyWeek5/5B-0.6.1-Source.zip
+ source = 555-boom.desktop
+ md5sums = 52a648e2c8d7e2efff0e1488a47c07ff
+ md5sums = b3f77a50856debc8d6b5bb98ade65f90
+
+pkgname = 555-boom
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f5a385a0261b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+*.asc
+*.bz2
+*.gz
+*.log
+*.part
+*.pkg
+pkg/
+*.scm
+*.sig
+*.sign
+src/
+*.txt
+*.xz
+*.zip
diff --git a/555-boom.desktop b/555-boom.desktop
new file mode 100644
index 000000000000..3e9d440c4c01
--- /dev/null
+++ b/555-boom.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Exec=555-boom.sh
+Type=Application
+Categories=Application;Game;BoardGame;
+Name=555-boom
+GenericName=555-boom
+Comment=A Puzzle Game and Electromechanical Sandbox.
+Terminal=false
+StartupNotify=false
+Icon=/usr/share/555-boom/Game/Resources/images/boom.png \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e432abd7caad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Lex Black <autumn-wind at web dot de>
+# Contributor: Dany Martineau <dany.luc.martineau at gmail.com>
+
+pkgname=555-boom
+pkgver=0.6.1
+pkgrel=4
+pkgdesc="Puzzle Game and Electromechanical Sandbox"
+url="http://www.cosc.canterbury.ac.nz/greg.ewing/python/PyWeek5/index.html"
+license=('GPL')
+arch=('any')
+depends=('python2-pygame')
+source=(http://www.cosc.canterbury.ac.nz/greg.ewing/python/PyWeek5/5B-${pkgver}-Source.zip
+ 555-boom.desktop)
+md5sums=('52a648e2c8d7e2efff0e1488a47c07ff'
+ 'b3f77a50856debc8d6b5bb98ade65f90')
+
+
+prepare() {
+ echo "#!/bin/bash" >> 555-boom.sh
+ echo "cd /usr/share/555-boom/Game" >> 555-boom.sh
+ echo "python2 run_game.py" >> 555-boom.sh
+}
+
+package() {
+ cd ${srcdir}/5B-$pkgver-Source
+
+ mkdir -p ${pkgdir}/usr/share/{555-boom,applications}
+ cp -R * ${pkgdir}/usr/share/555-boom
+ chmod 775 -R ${pkgdir}/usr/share/555-boom/{Saves,Mods}
+ chmod 555 -R ${pkgdir}/usr/share/555-boom/Game/Resources/levels
+
+ install -D -m 755 $srcdir/555-boom.sh ${pkgdir}/usr/bin/555-boom.sh
+ cp ${srcdir}/555-boom.desktop ${pkgdir}/usr/share/applications
+}