summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornaruto522ru2018-02-05 00:59:12 +0300
committernaruto522ru2018-02-05 00:59:12 +0300
commit79fa07b7d6734edb2f334e9907fc478c018a379e (patch)
treea00e72584a05351e1e00312dd8adcf6c1bab5a07
downloadaur-79fa07b7d6734edb2f334e9907fc478c018a379e.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b1e13ebc6f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = 5up
+ pkgdesc = Handy screenshot making tool. Take screenshots, crop them, draw on them by using built-in editor and share your screenshots over the Internet by instant upload to img.5cm.ru image hosting server.
+ pkgver = 1.7.3b3
+ pkgrel = 1
+ url = https://launchpad.net/~luza-mbox
+ arch = x86_64
+ license = GPL
+ makedepends = lib32-qt4
+ makedepends = libx11
+ depends = qt4
+ conflicts = 5up-bin
+ options = !strip
+ source = https://launchpad.net/~luza-mbox/+archive/ubuntu/ppa/+files/5up_1.7.3b3.orig.tar.gz
+ md5sums = 4f9b3e7ec5cb56782320a7e24a328d7b
+ sha256sums = 08452fee102b49e8f9e3846c5a20bb7b0cdedb77806afa068768def0552a7476
+
+pkgname = 5up
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df9390ebe7aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+#Maintainer: naruto522ru <itachi522ru@gmail.com>
+pkgname=5up
+pkgver=1.7.3b3
+pkgrel=1
+pkgdesc='Handy screenshot making tool. Take screenshots, crop them, draw on
+ them by using built-in editor and share your screenshots over the Internet by
+ instant upload to img.5cm.ru image hosting server.'
+arch=('x86_64')
+url='https://launchpad.net/~luza-mbox'
+license=('GPL')
+depends=('qt4')
+makedepends=('lib32-qt4' 'libx11')
+conflicts=('5up-bin')
+options=(!strip)
+source=("https://launchpad.net/~luza-mbox/+archive/ubuntu/ppa/+files/5up_$pkgver.orig.tar.gz")
+sha256sums=('08452fee102b49e8f9e3846c5a20bb7b0cdedb77806afa068768def0552a7476')
+md5sums=('4f9b3e7ec5cb56782320a7e24a328d7b')
+
+build() {
+ cd "$srcdir"/5up-1.7.3/
+ qmake-qt4 && make -j$(nproc)
+}
+
+package() {
+ install -dm 755 "$pkgdir/usr/share/licenses/$pkgname/"
+ install -dm 755 "$pkgdir/usr/bin/"
+
+ install -Dm 755 "$srcdir"/5up-1.7.3/docs/copyright "$pkgdir"/usr/share/licenses/$pkgname/
+ install -Dm 755 "$srcdir/5up-1.7.3/5up" "$pkgdir"/usr/bin/
+}
+