summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralesar12023-04-01 19:58:44 +0200
committeralesar12023-04-01 19:58:44 +0200
commit480c0d51d97e2810610869e6c1349c1b3f26fdb5 (patch)
treeeb989b2fd412ec808860b6d036c2bf602d497354
parent19daa0b81eefde2fbffae416756306dd9fa3366d (diff)
downloadaur-480c0d51d97e2810610869e6c1349c1b3f26fdb5.tar.gz
Fix linking with LZMA by Daniil Kovalev
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
-rw-r--r--fix-lzma-link.patch58
3 files changed, 71 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae42c7094483..a6b69cd2daa2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = 64gram-desktop
pkgdesc = Unofficial desktop version of Telegram messaging app
pkgver = 1.0.81
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/TDesktop-x64/tdesktop
arch = x86_64
@@ -41,6 +41,7 @@ pkgbase = 64gram-desktop
depends = libdispatch
depends = openssl-1.1
depends = protobuf
+ depends = xz
optdepends = webkit2gtk: embedded browser features
optdepends = xdg-desktop-portal: desktop integration
provides = telegram-desktop
@@ -48,7 +49,9 @@ pkgbase = 64gram-desktop
noextract = 64Gram-1.0.81-full.tar.gz
source = https://github.com/TDesktop-x64/tdesktop/releases/download/v1.0.81/64Gram-1.0.81-full.tar.gz
source = block-sponsored_messages.patch
+ source = fix-lzma-link.patch
sha512sums = 25bc2ef3462e4d3df579a91f4266b7f496e565c0c5fb4be92b7f6a78a2ff9aa03eff9f47712c2d0743afff4ab31caadefc905ecf5db4b62492fb35513ca0b7dc
sha512sums = c662524ca4f4a8df021ee94696d84896ed9a271df321933942806dda4544ea25f51a650ec8b4fc72f9a2219ea54cbfaf37b9604124f7263c86f74f1d647587ae
+ sha512sums = d813a5ac6ff2208b693ecf494d7bf036087e223662f9f34aaaeafea0afe0fe798e867b9610f7221ea80319865502c20b61310d5a31634b888793873d63322463
pkgname = 64gram-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 6eac2e74c01c..9b87360318c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Mantainer: Alesar1
+# Maintainer: Alesar1
# Contributor: solopasha <daron439 at gmail dot com>
# Contributor: KspLite <ksplite@outlook.com>
+# Contributor: Daniil Kovalev <daniil@kovalev.website>
pkgname=64gram-desktop
_pkgname=64Gram
pkgver=1.0.81
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc='Unofficial desktop version of Telegram messaging app'
arch=('x86_64')
@@ -13,7 +14,7 @@ license=('GPL3')
depends=('hunspell' 'ffmpeg' 'hicolor-icon-theme' 'lz4' 'minizip' 'openal' 'ttf-opensans'
'qt6-imageformats' 'qt6-svg' 'qt6-wayland' 'qt6-5compat' 'xxhash' 'glibmm-2.68'
'rnnoise' 'pipewire' 'libxtst' 'libxrandr' 'jemalloc' 'abseil-cpp' 'libdispatch'
- 'openssl-1.1' 'protobuf')
+ 'openssl-1.1' 'protobuf' 'xz')
makedepends=('cmake' 'git' 'ninja' 'python' 'range-v3' 'tl-expected' 'microsoft-gsl' 'meson'
'extra-cmake-modules' 'wayland-protocols' 'plasma-wayland-protocols' 'libtg_owt' 'p7zip')
optdepends=('webkit2gtk: embedded browser features'
@@ -21,16 +22,19 @@ optdepends=('webkit2gtk: embedded browser features'
provides=(telegram-desktop)
conflicts=(telegram-desktop)
source=("https://github.com/TDesktop-x64/tdesktop/releases/download/v${pkgver}/${_pkgname}-${pkgver}-full.tar.gz"
- "block-sponsored_messages.patch")
+ "block-sponsored_messages.patch"
+ "fix-lzma-link.patch")
noextract=("${_pkgname}-${pkgver}-full.tar.gz")
sha512sums=('25bc2ef3462e4d3df579a91f4266b7f496e565c0c5fb4be92b7f6a78a2ff9aa03eff9f47712c2d0743afff4ab31caadefc905ecf5db4b62492fb35513ca0b7dc'
- 'c662524ca4f4a8df021ee94696d84896ed9a271df321933942806dda4544ea25f51a650ec8b4fc72f9a2219ea54cbfaf37b9604124f7263c86f74f1d647587ae')
+ 'c662524ca4f4a8df021ee94696d84896ed9a271df321933942806dda4544ea25f51a650ec8b4fc72f9a2219ea54cbfaf37b9604124f7263c86f74f1d647587ae'
+ 'd813a5ac6ff2208b693ecf494d7bf036087e223662f9f34aaaeafea0afe0fe798e867b9610f7221ea80319865502c20b61310d5a31634b888793873d63322463')
prepare() {
7za x ${_pkgname}-${pkgver}-full.tar.gz
tar -xvf ${_pkgname}-${pkgver}-full.tar
cd $_pkgname-$pkgver-full
rm -rf Telegram/ThirdParty/libtgvoip/webrtc_dsp/absl
patch -Np1 --binary -i ../block-sponsored_messages.patch
+ patch -p1 --binary < ../fix-lzma-link.patch
}
build() {
diff --git a/fix-lzma-link.patch b/fix-lzma-link.patch
new file mode 100644
index 000000000000..0910685cb26b
--- /dev/null
+++ b/fix-lzma-link.patch
@@ -0,0 +1,58 @@
+c573b65a Fix linking with LZMA when auto update is disabled
+diff --git a/Telegram/CMakeLists.txt b/Telegram/CMakeLists.txt
+index 24c5909e..cb3ba61c 100644
+--- a/Telegram/CMakeLists.txt
++++ b/Telegram/CMakeLists.txt
+@@ -85,6 +85,7 @@ PRIVATE
+ desktop-app::external_qr_code_generator
+ desktop-app::external_crash_reports
+ desktop-app::external_auto_updates
++ desktop-app::external_lzma
+ desktop-app::external_openssl
+ desktop-app::external_openal
+ desktop-app::external_xxhash
+@@ -1710,6 +1711,7 @@ if ((NOT DESKTOP_APP_DISABLE_AUTOUPDATE OR APPLE) AND NOT build_macstore AND NOT
+ desktop-app::external_qt
+ desktop-app::external_zlib
+ desktop-app::external_auto_updates
++ desktop-app::external_lzma
+ desktop-app::external_openssl
+ )
+
+diff --git a/cmake/external/CMakeLists.txt b/cmake/external/CMakeLists.txt
+index 9be0e5a2..ed0b9aed 100644
+--- a/cmake/external/CMakeLists.txt
++++ b/cmake/external/CMakeLists.txt
+@@ -47,6 +47,7 @@ add_checked_subdirectory(jpeg)
+ add_checked_subdirectory(kcoreaddons)
+ add_checked_subdirectory(kimageformats)
+ add_checked_subdirectory(lz4)
++add_checked_subdirectory(lzma)
+ add_checked_subdirectory(minizip)
+ if (LINUX)
+ add_checked_subdirectory(nimf_qt5)
+diff --git a/cmake/external/lzma/CMakeLists.txt b/cmake/external/lzma/CMakeLists.txt
+new file mode 100644
+index 00000000..8e75394d
+--- /dev/null
++++ b/cmake/external/lzma/CMakeLists.txt
+@@ -0,0 +1,19 @@
++# This file is inspired by Desktop App Toolkit,
++# a set of libraries for developing nice desktop applications.
++#
++# For license and copyright information please follow this link:
++# https://github.com/desktop-app/legal/blob/master/LEGAL
++
++if (DESKTOP_APP_USE_PACKAGED)
++ if (DESKTOP_APP_DISABLE_AUTOUPDATE)
++ add_library(external_lzma INTERFACE IMPORTED GLOBAL)
++ add_library(desktop-app::external_lzma ALIAS external_lzma)
++ find_package(PkgConfig REQUIRED)
++ pkg_check_modules(LZMA REQUIRED IMPORTED_TARGET liblzma)
++ target_link_libraries(external_lzma INTERFACE PkgConfig::LZMA)
++ return()
++ else()
++ # See auto_update directory contents
++ endif()
++ message(FATAL_ERROR "DEKSTOP_APP_USE_PACKAGED expected to be TRUE")
++endif()