summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2015-06-08 11:35:33 -0600
committerAinola2015-06-08 11:35:33 -0600
commit1129880416e6119dc015135ec3a05da7ea8238cb (patch)
tree3568d306222e066a7fea840f8b18e16fc80895d5
downloadaur-1129880416e6119dc015135ec3a05da7ea8238cb.tar.gz
initial
-rw-r--r--.SRCINFO16
-rw-r--r--7-nanocycles.desktop10
-rw-r--r--PKGBUILD36
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55c68315292a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = 7-nanocycles
+ pkgdesc = 7 Nanocycles is a game of flying down an endless corridor of neon wire-meshes and geometrical shapes.
+ pkgver = 1
+ pkgrel = 2
+ url = http://nifflas.ni2.se/?page=Miscellaneous
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = glu
+ source = 7-nanocycles.zip::http://nifflas.ni2.se/content/Misc/7%20Nanocycles%20Linux.zip
+ source = 7-nanocycles.desktop
+ sha256sums = 2f159763c891ed68b572fe322f222121559769d37d3edf8c8a4e3034ecdbda93
+ sha256sums = bb2162b3a78bc95285ae81f67570a2210c84e186fbe8eff8431ad539ebb4a843
+
+pkgname = 7-nanocycles
+
diff --git a/7-nanocycles.desktop b/7-nanocycles.desktop
new file mode 100644
index 000000000000..5ee828ff72b3
--- /dev/null
+++ b/7-nanocycles.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=7 Nanocycles
+Comment=Play 7 Nanocycles
+Exec=7-nanocycles
+Icon=7-nanocycles
+Type=Application
+Terminal=false
+StartupNotify=true
+Categories=Game;AudioVideo;
+Encoding=UTF-8
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a184f0a2c32c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: ainola <opp310@alh.rqh> (ROT13)
+
+pkgname=7-nanocycles
+pkgver=1
+pkgrel=2
+pkgdesc="7 Nanocycles is a game of flying down an endless corridor of neon wire-meshes and geometrical shapes."
+arch=('i686' 'x86_64')
+url="http://nifflas.ni2.se/?page=Miscellaneous"
+license=('custom')
+depends=('glu')
+source=(7-nanocycles.zip::"http://nifflas.ni2.se/content/Misc/7%20Nanocycles%20Linux.zip"
+ "${pkgname}.desktop")
+sha256sums=("2f159763c891ed68b572fe322f222121559769d37d3edf8c8a4e3034ecdbda93"
+ "bb2162b3a78bc95285ae81f67570a2210c84e186fbe8eff8431ad539ebb4a843")
+[ "$CARCH" == "x86_64" ] && _arch="x86_64" || _arch="x86"
+
+package() {
+ # Launcher and Data
+ install -Dm755 "${srcdir}/7 Nanocycles.${_arch}" "${pkgdir}/opt/${pkgname}/7 Nanocycles.${_arch}"
+ mv "${srcdir}/7 Nanocycles_Data" "${pkgdir}/opt/${pkgname}/"
+
+ # Install Binaries/Launchers
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "/opt/${pkgname}/7 Nanocycles.${_arch}" "${pkgdir}/usr/bin/${pkgname}"
+
+ # Desktop Integration
+ mkdir -p "$pkgdir/usr/share/pixmaps"
+ ln -s "/opt/${pkgname}/7 Nanocycles_Data/Resources/UnityPlayer.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # Fix wonky permissions
+ find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} \;
+ find "${pkgdir}/opt/${pkgname}" -type f -exec chmod 644 {} \;
+ chmod 755 "${pkgdir}/opt/${pkgname}/7 Nanocycles.${_arch}"
+}