summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHanabishi2024-05-17 11:33:28 +0000
committerHanabishi2024-05-17 11:33:28 +0000
commite6916534e9b6ea2286dede4ac435ab39e8b7647e (patch)
treeadf176e4a153516cadcbac35ea2dc77451d5c242
parent52782c554210888680bcc268dced3a06db323c9d (diff)
downloadaur-e6916534e9b6ea2286dede4ac435ab39e8b7647e.tar.gz
Fix build with AVX512 support
-rw-r--r--.SRCINFO4
-rw-r--r--03-avx512-fix.patch21
-rw-r--r--PKGBUILD4
3 files changed, 27 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26b8d403da61..8e584b4d482c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = 7-zip-full
pkgdesc = File archiver with a high compression ratio (full package to replace p7zip)
pkgver = 24.05
- pkgrel = 1
+ pkgrel = 2
url = https://7-zip.org/
arch = x86_64
arch = i686
@@ -21,9 +21,11 @@ pkgbase = 7-zip-full
source = https://github.com/ip7z/7zip/releases/download/24.05/7z2405-linux-x64.tar.xz
source = 01-make.patch
source = 02-lib-load-path.patch
+ source = 03-avx512-fix.patch
sha256sums = 182d6e12ff8af0beafe46c9cd8e82b4271efb61c334c1068f8772777b535a03c
sha256sums = 7294f7478d90d2dc122137ff64607d354c66bd45b10911359658b85ca8892118
sha256sums = f54dfe73ad045f200d5512dfd4387ef626068662a5af6e17d81052996544af54
sha256sums = 338b732445d3cfa416e40384bd9f0596506aa4b464b3f86aa971af4cfa6084c7
+ sha256sums = ba77276422af8d818a10a252005de2d7694002e059c5557dd6cfe1e7b1761d96
pkgname = 7-zip-full
diff --git a/03-avx512-fix.patch b/03-avx512-fix.patch
new file mode 100644
index 000000000000..fe1071f7d2f9
--- /dev/null
+++ b/03-avx512-fix.patch
@@ -0,0 +1,21 @@
+--- a/C/Blake2s.c
++++ b/C/Blake2s.c
+@@ -1164,7 +1164,9 @@
+ #if 1 && defined(Z7_BLAKE2S_USE_AVX512_ALWAYS)
+ #define MM256_ROR_EPI32 _mm256_ror_epi32
+ #define Z7_MM256_ROR_EPI32_IS_SUPPORTED
++#ifdef Z7_BLAKE2S_USE_AVX2_WAY2
+ #define LOAD_ROTATE_CONSTS_256
++#endif
+ #else
+ #ifdef Z7_BLAKE2S_USE_AVX2_WAY_SLOW
+ #ifdef Z7_BLAKE2S_USE_AVX2_WAY2
+@@ -2548,7 +2550,7 @@
+ Z7_BLAKE2SP_FUNC_INIT func_Final = NULL;
+
+ #if defined(MY_CPU_X86_OR_AMD64)
+- #if defined(Z7_BLAKE2S_USE_AVX512_ALWAYS)
++ #if 0 && defined(Z7_BLAKE2S_USE_AVX512_ALWAYS)
+ if (CPU_IsSupported_AVX512F_AVX512VL())
+ #endif
+ #if defined(Z7_BLAKE2S_USE_SSE41)
diff --git a/PKGBUILD b/PKGBUILD
index 0b54364a75fa..e27513ffd160 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
_name=7-zip
pkgname=${_name}-full
pkgver=24.05
-pkgrel=1
+pkgrel=2
pkgdesc='File archiver with a high compression ratio (full package to replace p7zip)'
url='https://7-zip.org/'
license=('LGPL-2.1-or-later' 'BSD-3-Clause' 'LicenseRef-UnRAR')
@@ -20,6 +20,7 @@ source=(
"${_url}/releases/download/${pkgver}/${_manarc}" # to get the manual
'01-make.patch'
'02-lib-load-path.patch'
+ '03-avx512-fix.patch'
)
sha256sums=(
@@ -27,6 +28,7 @@ sha256sums=(
'7294f7478d90d2dc122137ff64607d354c66bd45b10911359658b85ca8892118'
'f54dfe73ad045f200d5512dfd4387ef626068662a5af6e17d81052996544af54'
'338b732445d3cfa416e40384bd9f0596506aa4b464b3f86aa971af4cfa6084c7'
+ 'ba77276422af8d818a10a252005de2d7694002e059c5557dd6cfe1e7b1761d96'
)
noextract=("${_manarc}")