summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcorey drew bruce2022-08-09 01:18:55 +1000
committercorey drew bruce2022-08-09 01:18:55 +1000
commit88bd84913a53807b3f7ac6e3a63284fd82fb01e9 (patch)
tree5b779d7a0a6dcc49824289f22f751d472d557d04
downloadaur-88bd84913a53807b3f7ac6e3a63284fd82fb01e9.tar.gz
7Plus 1.0.0-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..915df38c364d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = 7plus-bin
+ pkgdesc = Unofficial 7Plus desktop application.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://gitlab.com/7plus-application
+ arch = x86_64
+ arch = arm7h
+ arch = aarch64
+ license = GPL
+ makedepends = unzip
+ depends = nss
+ depends = gtk3
+ depends = libxss
+ conflicts = 7plus-git
+ source_x86_64 = https://gitlab.com/7plus-application/binaries/1.0.0-1/-/raw/main/7Plus-linux-x64.tar.gz
+ sha256sums_x86_64 = SKIP
+ source_aarch64 = https://gitlab.com/7plus-application/binaries/1.0.0-1/-/raw/main/7Plus-linux-arm64.tar.gz
+ sha256sums_aarch64 = SKIP
+
+pkgname = 7plus-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b5ed8dd485e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=7plus-bin
+_pkgname=7Plus-bin
+pkgver=1.0.0
+pkgrel=1
+_pkgrel_x86_64=1
+_pkgrel_armv7h=1
+_pkgrel_aarch64=1
+pkgdesc="Unofficial 7Plus desktop application."
+arch=('x86_64' 'arm7h' 'aarch64')
+url="https://gitlab.com/7plus-application"
+license=('GPL')
+depends=('nss' 'gtk3' 'libxss')
+makedepends=('unzip')
+conflicts=("7plus-git")
+sha256sums_x86_64=('SKIP')
+sha256sums_aarch64=('SKIP')
+sha256sums_armv7h=('SKIP')
+source_x86_64=("https://gitlab.com/7plus-application/binaries/"$pkgver"-"$pkgrel"/-/raw/main/7Plus-linux-x64.tar.gz")
+source_armv7h=("https://gitlab.com/7plus-application/binaries/"$pkgver"-"$pkgrel"/-/raw/main/7Plus-linux-armv7l.tar.gz")
+source_aarch64=("https://gitlab.com/7plus-application/binaries/"$pkgver"-"$pkgrel"/-/raw/main/7Plus-linux-arm64.tar.gz")
+
+package() {
+ for dir in 7Plus-linux-*/ ; do mv "${dir}" "$_pkgname" ;done
+ cd $_pkgname
+ install -dm755 "$pkgdir/opt/7Plus"
+ install -dm755 "$pkgdir/usr/share/pixmaps"
+ cp -r ./ "$pkgdir/opt/7Plus"
+ cp -r "$pkgdir/opt/7Plus/resources/app/7plus.svg" "$pkgdir/usr/share/pixmaps"
+
+
+ # Link to binary
+ install -dm755 "$pkgdir/usr/bin"
+ ln -s "/opt/7Plus" "$pkgdir/usr/bin/7Plus"
+
+ # Desktop Entry
+ install -Dm644 "$srcdir/$_pkgname/resources/app/7Plus.desktop" \
+ "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ sed -i s%/usr/share%/opt% "$pkgdir/usr/share/applications/$_pkgname.desktop"
+} \ No newline at end of file