summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2021-03-14 11:38:39 +0330
committerMohammadreza Abdollahzadeh2021-03-14 11:38:39 +0330
commit03d8f44b73876ff50f3ef2c2a78523248baa0448 (patch)
tree15551ad52ad3eeabad4dc3939bb8eabd684e3496
parent4dba852ce5463d0b0854a6b2f6564c30548d18a9 (diff)
downloadaur-03d8f44b73876ff50f3ef2c2a78523248baa0448.tar.gz
initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 17 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dbbd0f08188c..6c00b2d202b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,14 @@
pkgbase = 7zip-bin
- pkgdesc = Official Linux port of command line version of 7-Zip (not to be confused with p7zip)
+ pkgdesc = Command-line file archiver with high compression ratio (official build).
pkgver = 21.01
pkgrel = 1
url = https://www.7-zip.org
arch = x86_64
- arch = i686
- arch = armv7l
- arch = aarch64
license = LGPL
- source_x86_64 = https://7-zip.org/a/7z2101-linux-x64.tar.xz
- md5sums_x86_64 = cc30db641a3127173ed0a9b8ef1e916a
- source_i686 = https://7-zip.org/a/7z2101-linux-x86.tar.xz
- md5sums_i686 = bd8b3d45efc9fdb6400cefa539dc8404
- source_armv7l = https://7-zip.org/a/7z2101-linux-arm.tar.xz
- md5sums_armv7l = 788d67ace25c9a213fcd0cc125ebe5f2
- source_aarch64 = https://7-zip.org/a/7z2101-linux-arm64.tar.xz
- md5sums_aarch64 = 5052cb0160af813d33f11b41f562e758
+ provides = 7zip
+ conflicts = 7zip
+ source = 7zip-bin-21.01.tar.xz::https://www.7-zip.org/a/7z2101-linux-x64.tar.xz
+ sha256sums = 63c93537b8fad1353c278e275ee0e9cd7f30bc7edd1fa44543f2478752b7caf9
pkgname = 7zip-bin
diff --git a/PKGBUILD b/PKGBUILD
index 6565b021c3a4..fd20829bffd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,20 @@
-# Maintainer: Leap of Azzam <sayyid.azzam.mufhadol@gmail.com>
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=7zip-bin
pkgver=21.01
-_pkgver=$(echo ${pkgver//./})
pkgrel=1
-pkgdesc="Official Linux port of command line version of 7-Zip (not to be confused with p7zip)"
-arch=('x86_64' 'i686' 'armv7l' 'aarch64')
+pkgdesc="Command-line file archiver with high compression ratio (official build)."
+arch=(x86_64)
url="https://www.7-zip.org"
license=('LGPL')
-source_x86_64=("https://7-zip.org/a/7z${_pkgver}-linux-x64.tar.xz")
-source_i686=("https://7-zip.org/a/7z${_pkgver}-linux-x86.tar.xz")
-source_armv7l=("https://7-zip.org/a/7z${_pkgver}-linux-arm.tar.xz")
-source_aarch64=("https://7-zip.org/a/7z${_pkgver}-linux-arm64.tar.xz")
-md5sums_x86_64=("cc30db641a3127173ed0a9b8ef1e916a")
-md5sums_i686=("bd8b3d45efc9fdb6400cefa539dc8404")
-md5sums_armv7l=("788d67ace25c9a213fcd0cc125ebe5f2")
-md5sums_aarch64=("5052cb0160af813d33f11b41f562e758")
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source=("${pkgname}-${pkgver}.tar.xz::https://www.7-zip.org/a/7z${pkgver//./}-linux-x64.tar.xz")
+sha256sums=('63c93537b8fad1353c278e275ee0e9cd7f30bc7edd1fa44543f2478752b7caf9')
package() {
- mkdir -p ${pkgdir}/usr/bin/
- install -m 755 7zz ${pkgdir}/usr/bin/
+ install -Dm755 7zz ${pkgdir}/usr/bin/7zz
+ install -d ${pkgdir}/usr/share/doc/${pkgname%-bin}
+ cp -a MANUAL History.txt readme.txt ${pkgdir}/usr/share/doc/${pkgname%-bin}/
+ install -Dm644 License.txt ${pkgdir}/usr/share/licenses/${pkgname%-bin}/LICENSE
}
+# vim:set ts=4 sw=4: