summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeap of Azzam2021-03-13 09:23:50 +0000
committerLeap of Azzam2021-03-13 09:23:50 +0000
commit325b5d90d39a71a1d297c8600ea8114b3d473fc2 (patch)
treef3f3ff4705462f40b898b1351abfff6172ea7f07
downloadaur-325b5d90d39a71a1d297c8600ea8114b3d473fc2.tar.gz
Initial release
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD22
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..336880bc3ac0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = 7zip-bin
+ pkgdesc = Official Linux port of command line version of 7-Zip (not to be confused with p7zip)
+ pkgver = 21.01
+ pkgrel = 1
+ url = https://www.7-zip.org
+ arch = x86_64
+ arch = i686
+ arch = armv7l
+ arch = aarch64
+ license = GPL
+ source_x86_64 = https://7-zip.org/a/7z2101-linux-x64.tar.xz
+ md5sums_x86_64 = cc30db641a3127173ed0a9b8ef1e916a
+ source_i686 = https://7-zip.org/a/7z2101-linux-x86.tar.xz
+ md5sums_i686 = bd8b3d45efc9fdb6400cefa539dc8404
+ source_armv7l = https://7-zip.org/a/7z2101-linux-arm.tar.xz
+ md5sums_armv7l = 788d67ace25c9a213fcd0cc125ebe5f2
+ source_aarch64 = https://7-zip.org/a/7z2101-linux-arm64.tar.xz
+ md5sums_aarch64 = 5052cb0160af813d33f11b41f562e758
+
+pkgname = 7zip-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9cefeb2c532
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Leap of Azzam <sayyid.azzam.mufhadol@gmail.com>
+pkgname=7zip-bin
+pkgver=21.01
+_pkgver=$(echo ${pkgver//./})
+pkgrel=1
+pkgdesc="Official Linux port of command line version of 7-Zip (not to be confused with p7zip)"
+arch=('x86_64' 'i686' 'armv7l' 'aarch64')
+url="https://www.7-zip.org"
+license=('GPL')
+source_x86_64=("https://7-zip.org/a/7z${_pkgver}-linux-x64.tar.xz")
+source_i686=("https://7-zip.org/a/7z${_pkgver}-linux-x86.tar.xz")
+source_armv7l=("https://7-zip.org/a/7z${_pkgver}-linux-arm.tar.xz")
+source_aarch64=("https://7-zip.org/a/7z${_pkgver}-linux-arm64.tar.xz")
+md5sums_x86_64=("cc30db641a3127173ed0a9b8ef1e916a")
+md5sums_i686=("bd8b3d45efc9fdb6400cefa539dc8404")
+md5sums_armv7l=("788d67ace25c9a213fcd0cc125ebe5f2")
+md5sums_aarch64=("5052cb0160af813d33f11b41f562e758")
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin/
+ install -m 755 7zz ${pkgdir}/usr/bin/
+}