summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArpan Kapoor2023-02-09 11:54:24 +0530
committerArpan Kapoor2023-02-09 11:54:24 +0530
commitc9e79819584ed1e06fd1d325d46b7c7bc9010d54 (patch)
tree9a0050285894501457544202bcc3c58d40d4d384
parent7b7b1cdfb0ea4f9003ad944d2ffde090a743b232 (diff)
downloadaur-8188eu-dkms.tar.gz
update to latest kernel version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--linux-5.15.patch61
-rw-r--r--linux-5.17.patch58
-rw-r--r--linux-6.1.patch20
5 files changed, 153 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73cfc5b0adc6..17fbfafe5bdc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = 8188eu-dkms
pkgdesc = Driver for Realtek RTL8188EUS (RTL8188EUS, RTL8188ETV) WLAN
pkgver = v4.3.0.8_13968
- pkgrel = 16
+ pkgrel = 17
url = http://www.realtek.com.tw/
arch = any
license = GPL
@@ -24,6 +24,9 @@ pkgbase = 8188eu-dkms
source = linux-5.6.patch
source = linux-5.8.patch
source = linux-5.10.patch
+ source = linux-5.15.patch
+ source = linux-5.17.patch
+ source = linux-6.1.patch
source = no_debug.patch
md5sums = ca8736349079bc2bfedfb862d04a08bb
md5sums = 8af5df9ed717b3bb48df59dac0c8a9c8
@@ -43,6 +46,9 @@ pkgbase = 8188eu-dkms
md5sums = d3d112aec7a0cdccc7161ba1d66b8475
md5sums = 96d4403315c7af254d2be5706b726317
md5sums = 8906dbc463e885aa6aa95679e5c5f659
+ md5sums = d1a376d74a61f09b7333f40a2ac9c594
+ md5sums = 7ae884b13d823469d7957a1a59dd2317
+ md5sums = 468076c497b7225d60cf622482ca7759
md5sums = 0b14ee4517f78ada4d471654afd82b79
pkgname = 8188eu-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 9ba8db2d2ef3..d584e09fa68b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=8188eu
pkgname="${_pkgname}-dkms"
pkgver=v4.3.0.8_13968
-pkgrel=16
+pkgrel=17
pkgdesc='Driver for Realtek RTL8188EUS (RTL8188EUS, RTL8188ETV) WLAN'
arch=('any')
url='http://www.realtek.com.tw/'
@@ -27,6 +27,9 @@ source=("https://www.dropbox.com/s/afs5d2yfgwurqm2/${_pkgname}-${pkgver}.tar.xz?
linux-5.6.patch
linux-5.8.patch
linux-5.10.patch
+ linux-5.15.patch
+ linux-5.17.patch
+ linux-6.1.patch
no_debug.patch)
md5sums=('ca8736349079bc2bfedfb862d04a08bb'
'8af5df9ed717b3bb48df59dac0c8a9c8'
@@ -46,6 +49,9 @@ md5sums=('ca8736349079bc2bfedfb862d04a08bb'
'd3d112aec7a0cdccc7161ba1d66b8475'
'96d4403315c7af254d2be5706b726317'
'8906dbc463e885aa6aa95679e5c5f659'
+ 'd1a376d74a61f09b7333f40a2ac9c594'
+ '7ae884b13d823469d7957a1a59dd2317'
+ '468076c497b7225d60cf622482ca7759'
'0b14ee4517f78ada4d471654afd82b79')
prepare() {
diff --git a/linux-5.15.patch b/linux-5.15.patch
new file mode 100644
index 000000000000..44bf0621b1f5
--- /dev/null
+++ b/linux-5.15.patch
@@ -0,0 +1,61 @@
+diff --git a/core/rtw_br_ext.c b/core/rtw_br_ext.c
+index 88a517a..9c4ad22 100644
+--- a/core/rtw_br_ext.c
++++ b/core/rtw_br_ext.c
+@@ -22,7 +22,12 @@
+ #ifdef __KERNEL__
+ #include <linux/if_arp.h>
+ #include <net/ip.h>
+-#include <net/ipx.h>
++
++#include <linux/version.h>
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(5, 15, 0))
++ #include <net/ipx.h>
++#endif
++
+ #include <linux/atalk.h>
+ #include <linux/udp.h>
+ #include <linux/if_pppox.h>
+@@ -170,6 +175,7 @@ static __inline__ void __nat25_generate_ipv4_network_addr(unsigned char *network
+ }
+
+
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(5, 15, 0))
+ static __inline__ void __nat25_generate_ipx_network_addr_with_node(unsigned char *networkAddr,
+ unsigned int *ipxNetAddr, unsigned char *ipxNodeAddr)
+ {
+@@ -179,8 +185,10 @@ static __inline__ void __nat25_generate_ipx_network_addr_with_node(unsigned char
+ memcpy(networkAddr+1, (unsigned char *)ipxNetAddr, 4);
+ memcpy(networkAddr+5, ipxNodeAddr, 6);
+ }
++#endif
+
+
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(5, 15, 0))
+ static __inline__ void __nat25_generate_ipx_network_addr_with_socket(unsigned char *networkAddr,
+ unsigned int *ipxNetAddr, unsigned short *ipxSocketAddr)
+ {
+@@ -190,6 +198,7 @@ static __inline__ void __nat25_generate_ipx_network_addr_with_socket(unsigned ch
+ memcpy(networkAddr+1, (unsigned char *)ipxNetAddr, 4);
+ memcpy(networkAddr+5, (unsigned char *)ipxSocketAddr, 2);
+ }
++#endif
+
+
+ static __inline__ void __nat25_generate_apple_network_addr(unsigned char *networkAddr,
+@@ -930,6 +939,7 @@ int nat25_db_handle(_adapter *priv, struct sk_buff *skb, int method)
+ /*---------------------------------------------------*/
+ /* Handle IPX and Apple Talk frame */
+ /*---------------------------------------------------*/
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(5, 15, 0))
+ else if((protocol == __constant_htons(ETH_P_IPX)) ||
+ (protocol <= __constant_htons(ETH_FRAME_LEN)))
+ {
+@@ -1190,6 +1200,7 @@ int nat25_db_handle(_adapter *priv, struct sk_buff *skb, int method)
+
+ return -1;
+ }
++#endif
+
+ /*---------------------------------------------------*/
+ /* Handle PPPoE frame */
diff --git a/linux-5.17.patch b/linux-5.17.patch
new file mode 100644
index 000000000000..f263e9277779
--- /dev/null
+++ b/linux-5.17.patch
@@ -0,0 +1,58 @@
+diff --git a/include/ieee80211.h b/include/ieee80211.h
+index fc293c4..0898cd4 100644
+--- a/include/ieee80211.h
++++ b/include/ieee80211.h
+@@ -1314,18 +1314,18 @@ enum ieee80211_state {
+ (((Addr[2]) & 0xff) == 0xff) && (((Addr[3]) & 0xff) == 0xff) && (((Addr[4]) & 0xff) == 0xff) && \
+ (((Addr[5]) & 0xff) == 0xff))
+ #else
+-extern __inline int is_multicast_mac_addr(const u8 *addr)
++static __inline int is_multicast_mac_addr(const u8 *addr)
+ {
+ return ((addr[0] != 0xff) && (0x01 & addr[0]));
+ }
+
+-extern __inline int is_broadcast_mac_addr(const u8 *addr)
++static __inline int is_broadcast_mac_addr(const u8 *addr)
+ {
+ return ((addr[0] == 0xff) && (addr[1] == 0xff) && (addr[2] == 0xff) && \
+ (addr[3] == 0xff) && (addr[4] == 0xff) && (addr[5] == 0xff));
+ }
+
+-extern __inline int is_zero_mac_addr(const u8 *addr)
++static __inline int is_zero_mac_addr(const u8 *addr)
+ {
+ return ((addr[0] == 0x00) && (addr[1] == 0x00) && (addr[2] == 0x00) && \
+ (addr[3] == 0x00) && (addr[4] == 0x00) && (addr[5] == 0x00));
+diff --git a/include/osdep_service_linux.h b/include/osdep_service_linux.h
+index d733520..cfa7d2f 100644
+--- a/include/osdep_service_linux.h
++++ b/include/osdep_service_linux.h
+@@ -153,7 +153,12 @@
+ typedef int thread_return;
+ typedef void* thread_context;
+
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(5, 17, 0))
+ #define thread_exit() complete_and_exit(NULL, 0)
++#else
++ #define thread_exit() kthread_complete_and_exit(NULL, 0)
++#endif
++
+
+ typedef void timer_hdl_return;
+ typedef void* timer_hdl_context;
+diff --git a/os_dep/linux/rtw_proc.c b/os_dep/linux/rtw_proc.c
+index 8e0f7dd..cf8f3a0 100644
+--- a/os_dep/linux/rtw_proc.c
++++ b/os_dep/linux/rtw_proc.c
+@@ -41,6 +41,10 @@ inline struct proc_dir_entry *get_rtw_drv_proc(void)
+ #define proc_get_parent_data(inode) PDE((inode))->parent->data
+ #endif
+
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(5, 17, 0))
++#define PDE_DATA(inode) pde_data(inode)
++#endif
++
+ #if(LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ #define get_proc_net proc_net
+ #else
diff --git a/linux-6.1.patch b/linux-6.1.patch
new file mode 100644
index 000000000000..89ffbe7e85c7
--- /dev/null
+++ b/linux-6.1.patch
@@ -0,0 +1,20 @@
+diff --git a/os_dep/osdep_service.c b/os_dep/osdep_service.c
+index 7d1ab56..bfc939b 100644
+--- a/os_dep/osdep_service.c
++++ b/os_dep/osdep_service.c
+@@ -2327,9 +2327,13 @@ inline u32 rtw_random32(void)
+ {
+ #ifdef PLATFORM_LINUX
+ #if (LINUX_VERSION_CODE >= KERNEL_VERSION(3,8,0))
+- return prandom_u32();
++ #if (LINUX_VERSION_CODE < KERNEL_VERSION(6,1,0))
++ return prandom_u32();
++ #else
++ return get_random_u32();
++ #endif
+ #else
+- return random32();
++ return random32();
+ #endif
+ #elif defined(PLATFORM_WINDOWS)
+ #error "to be implemented\n"