summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArpan Kapoor2019-08-25 07:48:55 +0530
committerArpan Kapoor2019-08-25 07:48:55 +0530
commit270d7912afa3d112dc0898c2e013dff294c9332c (patch)
treef9c6974356af70dea0a90a694fb43312fda0cb98
parentcc4d02bd40208928458506540ad7b77e0814f53f (diff)
downloadaur-270d7912afa3d112dc0898c2e013dff294c9332c.tar.gz
fix for kernel 5.2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--linux-5.2.patch13
3 files changed, 19 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb7896ea1398..61e4d99f9e98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = 8188eu-dkms
pkgdesc = Driver for Realtek RTL8188EUS (RTL8188EUS, RTL8188ETV) WLAN
pkgver = v4.3.0.8_13968
- pkgrel = 11
+ pkgrel = 12
url = http://www.realtek.com.tw/
install = 8188eu-dkms.install
arch = any
@@ -21,6 +21,7 @@ pkgbase = 8188eu-dkms
source = linux-4.19.patch
source = linux-5.0.patch
source = linux-5.1.patch
+ source = linux-5.2.patch
source = no_debug.patch
sha256sums = c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832
sha256sums = edaeafe28410017fabb742d6ccdf060a945150fb56e41084adb7b9dd66739e2b
@@ -36,6 +37,7 @@ pkgbase = 8188eu-dkms
sha256sums = eb1eed7298dc9ee8b39e59cc25a5ae03755337564538755d87fc808c493ac267
sha256sums = 0655f764a9e412ee1cb53b432938f56aa2f26f0ff28617b0b6833530a1bdb388
sha256sums = d607fc3dc1b0a1364add8a90a15a56e77cea372f02d93b9bb6d13c56d5c0055b
+ sha256sums = 91c0ab11f0792773d7cba748e31f12f98101c52d732e0ab159c38bfbb53435b7
sha256sums = 9b8453c15e39cf68ccc1a0d7dfb093439f89e3b2e7c40dd0fa8d0b8aa9956cdd
pkgname = 8188eu-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 9a6eac3e4000..7bc573ac8467 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=8188eu
pkgname="${_pkgname}-dkms"
pkgver=v4.3.0.8_13968
-pkgrel=11
+pkgrel=12
pkgdesc='Driver for Realtek RTL8188EUS (RTL8188EUS, RTL8188ETV) WLAN'
arch=('any')
url='http://www.realtek.com.tw/'
@@ -24,6 +24,7 @@ source=("https://www.dropbox.com/s/afs5d2yfgwurqm2/${_pkgname}-${pkgver}.tar.xz?
linux-4.19.patch
linux-5.0.patch
linux-5.1.patch
+ linux-5.2.patch
no_debug.patch)
sha256sums=('c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832'
'edaeafe28410017fabb742d6ccdf060a945150fb56e41084adb7b9dd66739e2b'
@@ -39,6 +40,7 @@ sha256sums=('c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832'
'eb1eed7298dc9ee8b39e59cc25a5ae03755337564538755d87fc808c493ac267'
'0655f764a9e412ee1cb53b432938f56aa2f26f0ff28617b0b6833530a1bdb388'
'd607fc3dc1b0a1364add8a90a15a56e77cea372f02d93b9bb6d13c56d5c0055b'
+ '91c0ab11f0792773d7cba748e31f12f98101c52d732e0ab159c38bfbb53435b7'
'9b8453c15e39cf68ccc1a0d7dfb093439f89e3b2e7c40dd0fa8d0b8aa9956cdd')
prepare() {
diff --git a/linux-5.2.patch b/linux-5.2.patch
new file mode 100644
index 000000000000..05bb9aa5feed
--- /dev/null
+++ b/linux-5.2.patch
@@ -0,0 +1,13 @@
+diff --git a/os_dep/linux/os_intfs.c b/os_dep/linux/os_intfs.c
+index 2d88a1b..8af779d 100644
+--- a/os_dep/linux/os_intfs.c
++++ b/os_dep/linux/os_intfs.c
+@@ -636,7 +636,7 @@ static u16 rtw_select_queue(struct net_device *dev, struct sk_buff *skb
+ , struct net_device *sb_dev
+ #endif
+ #endif
+-#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 14, 0)
++#if (LINUX_VERSION_CODE >= KERNEL_VERSION(3, 14, 0) && LINUX_VERSION_CODE < KERNEL_VERSION(5, 2, 0))
+ , select_queue_fallback_t fallback
+ #endif
+ )