summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArpan Kapoor2020-08-16 19:16:25 +0530
committerArpan Kapoor2020-08-16 19:16:25 +0530
commit8ca18835256c7bad82d606486d5b48ce0d8b825e (patch)
tree132c6c25703852673f8759e50852a69cea3a8cc9
parentd6a94da16eed3f6873507d0096c8711ecf28f6f4 (diff)
downloadaur-8ca18835256c7bad82d606486d5b48ce0d8b825e.tar.gz
fix for 5.8
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--linux-5.8.patch62
3 files changed, 68 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34bacaf993ba..cfa9ca8ee27e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = 8188eu-dkms
pkgdesc = Driver for Realtek RTL8188EUS (RTL8188EUS, RTL8188ETV) WLAN
pkgver = v4.3.0.8_13968
- pkgrel = 13
+ pkgrel = 14
url = http://www.realtek.com.tw/
install = 8188eu-dkms.install
arch = any
@@ -23,6 +23,7 @@ pkgbase = 8188eu-dkms
source = linux-5.1.patch
source = linux-5.2.patch
source = linux-5.6.patch
+ source = linux-5.8.patch
source = no_debug.patch
md5sums = ca8736349079bc2bfedfb862d04a08bb
md5sums = 8af5df9ed717b3bb48df59dac0c8a9c8
@@ -40,6 +41,7 @@ pkgbase = 8188eu-dkms
md5sums = 4730b05761b7bc9b3e970a088fc81c8f
md5sums = 0f23196d2f3be2aff32393c698c10d7a
md5sums = d3d112aec7a0cdccc7161ba1d66b8475
+ md5sums = 96d4403315c7af254d2be5706b726317
md5sums = 0b14ee4517f78ada4d471654afd82b79
pkgname = 8188eu-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 4467bb6634d3..0397d93b18d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=8188eu
pkgname="${_pkgname}-dkms"
pkgver=v4.3.0.8_13968
-pkgrel=13
+pkgrel=14
pkgdesc='Driver for Realtek RTL8188EUS (RTL8188EUS, RTL8188ETV) WLAN'
arch=('any')
url='http://www.realtek.com.tw/'
@@ -26,6 +26,7 @@ source=("https://www.dropbox.com/s/afs5d2yfgwurqm2/${_pkgname}-${pkgver}.tar.xz?
linux-5.1.patch
linux-5.2.patch
linux-5.6.patch
+ linux-5.8.patch
no_debug.patch)
md5sums=('ca8736349079bc2bfedfb862d04a08bb'
'8af5df9ed717b3bb48df59dac0c8a9c8'
@@ -43,6 +44,7 @@ md5sums=('ca8736349079bc2bfedfb862d04a08bb'
'4730b05761b7bc9b3e970a088fc81c8f'
'0f23196d2f3be2aff32393c698c10d7a'
'd3d112aec7a0cdccc7161ba1d66b8475'
+ '96d4403315c7af254d2be5706b726317'
'0b14ee4517f78ada4d471654afd82b79')
prepare() {
diff --git a/linux-5.8.patch b/linux-5.8.patch
new file mode 100644
index 000000000000..8a5e79d31b1c
--- /dev/null
+++ b/linux-5.8.patch
@@ -0,0 +1,62 @@
+diff --git a/core/rtw_security.c b/core/rtw_security.c
+index 9841568..2746289 100644
+--- a/core/rtw_security.c
++++ b/core/rtw_security.c
+@@ -2281,7 +2281,7 @@ BIP_exit:
+
+ #ifndef PLATFORM_FREEBSD
+ /* compress 512-bits */
+-static int sha256_compress(struct sha256_state *md, unsigned char *buf)
++static int sha256_compress(struct rtw_sha256_state *md, unsigned char *buf)
+ {
+ u32 S[8], W[64], t0, t1;
+ u32 t;
+@@ -2323,7 +2323,7 @@ static int sha256_compress(struct sha256_state *md, unsigned char *buf)
+ }
+
+ /* Initialize the hash state */
+-static void sha256_init(struct sha256_state *md)
++static void sha256_init(struct rtw_sha256_state *md)
+ {
+ md->curlen = 0;
+ md->length = 0;
+@@ -2344,7 +2344,7 @@ static void sha256_init(struct sha256_state *md)
+ @param inlen The length of the data (octets)
+ @return CRYPT_OK if successful
+ */
+-static int sha256_process(struct sha256_state *md, unsigned char *in,
++static int sha256_process(struct rtw_sha256_state *md, unsigned char *in,
+ unsigned long inlen)
+ {
+ unsigned long n;
+@@ -2385,7 +2385,7 @@ static int sha256_process(struct sha256_state *md, unsigned char *in,
+ @param out [out] The destination of the hash (32 bytes)
+ @return CRYPT_OK if successful
+ */
+-static int sha256_done(struct sha256_state *md, unsigned char *out)
++static int sha256_done(struct rtw_sha256_state *md, unsigned char *out)
+ {
+ int i;
+
+@@ -2437,7 +2437,7 @@ static int sha256_done(struct sha256_state *md, unsigned char *out)
+ static int sha256_vector(size_t num_elem, u8 *addr[], size_t *len,
+ u8 *mac)
+ {
+- struct sha256_state ctx;
++ struct rtw_sha256_state ctx;
+ size_t i;
+
+ sha256_init(&ctx);
+diff --git a/include/rtw_security.h b/include/rtw_security.h
+index 00b08fd..c350665 100644
+--- a/include/rtw_security.h
++++ b/include/rtw_security.h
+@@ -235,7 +235,7 @@ struct security_priv
+ #endif /* DBG_SW_SEC_CNT */
+ };
+
+-struct sha256_state {
++struct rtw_sha256_state {
+ u64 length;
+ u32 state[8], curlen;
+ u8 buf[64];