summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArpan Kapoor2019-05-17 22:30:49 +0530
committerArpan Kapoor2019-05-17 22:30:49 +0530
commitcc4d02bd40208928458506540ad7b77e0814f53f (patch)
tree9ceccf709ab648c4b296da8d385c1a9609beda66
parent39a89670ffc923125a2e48ef9c9aad96fabdca4f (diff)
downloadaur-cc4d02bd40208928458506540ad7b77e0814f53f.tar.gz
fixes for kernel 5.1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--linux-5.1.patch31
3 files changed, 37 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d903394dd23..bb7896ea1398 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = 8188eu-dkms
pkgdesc = Driver for Realtek RTL8188EUS (RTL8188EUS, RTL8188ETV) WLAN
pkgver = v4.3.0.8_13968
- pkgrel = 10
+ pkgrel = 11
url = http://www.realtek.com.tw/
install = 8188eu-dkms.install
arch = any
@@ -20,6 +20,7 @@ pkgbase = 8188eu-dkms
source = linux-4.15.patch
source = linux-4.19.patch
source = linux-5.0.patch
+ source = linux-5.1.patch
source = no_debug.patch
sha256sums = c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832
sha256sums = edaeafe28410017fabb742d6ccdf060a945150fb56e41084adb7b9dd66739e2b
@@ -34,6 +35,7 @@ pkgbase = 8188eu-dkms
sha256sums = 18c1aeb9b574c1ecd689435908adbd006bb73f2a723f319e18f044b9c3a3f6dd
sha256sums = eb1eed7298dc9ee8b39e59cc25a5ae03755337564538755d87fc808c493ac267
sha256sums = 0655f764a9e412ee1cb53b432938f56aa2f26f0ff28617b0b6833530a1bdb388
+ sha256sums = d607fc3dc1b0a1364add8a90a15a56e77cea372f02d93b9bb6d13c56d5c0055b
sha256sums = 9b8453c15e39cf68ccc1a0d7dfb093439f89e3b2e7c40dd0fa8d0b8aa9956cdd
pkgname = 8188eu-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 8b036a6236d6..9a6eac3e4000 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=8188eu
pkgname="${_pkgname}-dkms"
pkgver=v4.3.0.8_13968
-pkgrel=10
+pkgrel=11
pkgdesc='Driver for Realtek RTL8188EUS (RTL8188EUS, RTL8188ETV) WLAN'
arch=('any')
url='http://www.realtek.com.tw/'
@@ -23,6 +23,7 @@ source=("https://www.dropbox.com/s/afs5d2yfgwurqm2/${_pkgname}-${pkgver}.tar.xz?
linux-4.15.patch
linux-4.19.patch
linux-5.0.patch
+ linux-5.1.patch
no_debug.patch)
sha256sums=('c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832'
'edaeafe28410017fabb742d6ccdf060a945150fb56e41084adb7b9dd66739e2b'
@@ -37,6 +38,7 @@ sha256sums=('c5604632f88ab6c68074635c73403a3f612f9f69b52af8fe9b96cf851db7a832'
'18c1aeb9b574c1ecd689435908adbd006bb73f2a723f319e18f044b9c3a3f6dd'
'eb1eed7298dc9ee8b39e59cc25a5ae03755337564538755d87fc808c493ac267'
'0655f764a9e412ee1cb53b432938f56aa2f26f0ff28617b0b6833530a1bdb388'
+ 'd607fc3dc1b0a1364add8a90a15a56e77cea372f02d93b9bb6d13c56d5c0055b'
'9b8453c15e39cf68ccc1a0d7dfb093439f89e3b2e7c40dd0fa8d0b8aa9956cdd')
prepare() {
diff --git a/linux-5.1.patch b/linux-5.1.patch
new file mode 100644
index 000000000000..a54f29311645
--- /dev/null
+++ b/linux-5.1.patch
@@ -0,0 +1,31 @@
+diff --git a/os_dep/osdep_service.c b/os_dep/osdep_service.c
+index 97a904b..8c21b7e 100644
+--- a/os_dep/osdep_service.c
++++ b/os_dep/osdep_service.c
+@@ -1938,7 +1938,7 @@ static int isFileReadable(char *path)
+ ret = PTR_ERR(fp);
+ }
+ else {
+- oldfs = get_fs(); set_fs(get_ds());
++ oldfs = get_fs(); set_fs(KERNEL_DS);
+
+ if(1!=readFile(fp, &buf, 1))
+ ret = PTR_ERR(fp);
+@@ -1966,7 +1966,7 @@ static int retriveFromFile(char *path, u8* buf, u32 sz)
+ if( 0 == (ret=openFile(&fp,path, O_RDONLY, 0)) ){
+ DBG_871X("%s openFile path:%s fp=%p\n",__FUNCTION__, path ,fp);
+
+- oldfs = get_fs(); set_fs(get_ds());
++ oldfs = get_fs(); set_fs(KERNEL_DS);
+ ret=readFile(fp, buf, sz);
+ set_fs(oldfs);
+ closeFile(fp);
+@@ -2000,7 +2000,7 @@ static int storeToFile(char *path, u8* buf, u32 sz)
+ if( 0 == (ret=openFile(&fp, path, O_CREAT|O_WRONLY, 0666)) ) {
+ DBG_871X("%s openFile path:%s fp=%p\n",__FUNCTION__, path ,fp);
+
+- oldfs = get_fs(); set_fs(get_ds());
++ oldfs = get_fs(); set_fs(KERNEL_DS);
+ ret=writeFile(fp, buf, sz);
+ set_fs(oldfs);
+ closeFile(fp);