summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjorn Neergaard2015-06-09 08:17:04 -0700
committerBjorn Neergaard2015-06-09 08:17:04 -0700
commitb4c2de64b41b8e07787fc5fa74d065897d521769 (patch)
tree28f8c0e90f81875ae96cdb434669b31164d87458
downloadaur-b4c2de64b41b8e07787fc5fa74d065897d521769.tar.gz
Initial import.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD42
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c8c05f63851
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = 915resolution
+ pkgdesc = A tool to modify the video BIOS of the 800 and 900 series Intel graphics chipsets
+ pkgver = 0.5.3
+ pkgrel = 1
+ url = http://915resolution.mango-lang.org/
+ arch = i686
+ arch = x86_64
+ license = custom:Public Domain
+ depends = bash
+ source = http://915resolution.mango-lang.org/915resolution-0.5.3.tar.gz
+ sha256sums = b64cab834b5e410bca555dc9db8e69f62f6f02496942f35ff4a68f3f27f1b542
+
+pkgname = 915resolution
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e93c323e6100
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Bjorn Neergaard (neersighted) <bjorn@neersighted.com>
+# Contributor: legolas558 <legolas558@users.sourceforge.net>
+# Contributor: nightfrost <khashayar_naderehvandi@yahoo.co.uk>
+
+_pkgname=915resolution
+pkgname=915resolution
+pkgver=0.5.3
+pkgrel=1
+pkgdesc='A tool to modify the video BIOS of the 800 and 900 series Intel graphics chipsets'
+url='http://915resolution.mango-lang.org/'
+license=('custom:Public Domain')
+source=("http://915resolution.mango-lang.org/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('b64cab834b5e410bca555dc9db8e69f62f6f02496942f35ff4a68f3f27f1b542')
+arch=('i686' 'x86_64')
+depends=('bash')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ # Clean out the bundled binaries.
+ make clean
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ # Build it!
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ # Install the program.
+ install -Dm755 915resolution "${pkgdir}/usr/bin/915resolution"
+ install -Dm755 dump_bios "${pkgdir}/usr/bin/915dump_bios"
+
+ # Install the license.
+ install -Dm755 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ft=sh ts=2 sw=2 et