summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2022-09-29 22:06:49 +0200
committerChristopher Arndt2022-09-29 22:06:49 +0200
commit31f2ba65d3533f9b3794a152e988d70fca0dd024 (patch)
tree223ee9b52a207f90d66d6d69c094dcddc193bb30
parentfcd3e5fc0b91767a9d5a82b95844dc05a0885a21 (diff)
downloadaur-31f2ba65d3533f9b3794a152e988d70fca0dd024.tar.gz
New upstream version 1.0.3
Add patch for proper linking of VST3 shared lib.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--a-sid-build-linux.patch23
3 files changed, 39 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1f94fdd7d80..0f8ec279a73e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = a-sid
pkgdesc = Emulation of the C64 MOS 8580 SID analog filter as a VST3 plugin
- pkgver = 1.0.2
+ pkgver = 1.0.3
pkgrel = 1
url = https://www.orastron.com/asid
arch = x86_64
@@ -10,7 +10,11 @@ pkgbase = a-sid
license = MIT
makedepends = vst3sdk
depends = glibc
- source = a-sid-1.0.2.tar.gz::https://github.com/sdangelo/asid/archive/refs/tags/1.0.2.tar.gz
- sha256sums = 76bf5e925b2aed577b2eea255cb3f972be6f4d5c3925898855eefdbdbfbad17d
+ depends = gcc-libs
+ depends = libxcb
+ source = a-sid-1.0.3.tar.gz::https://github.com/sdangelo/asid/archive/refs/tags/1.0.3.tar.gz
+ source = a-sid-build-linux.patch
+ sha256sums = 16bd9df96d763dfba3add95e643b48713fb22401e6f54df57cceaf5793f65a55
+ sha256sums = 0060a7758e066c83812b2f0c6944b7ca7c0f26e1226d271314507808b2b274f5
pkgname = a-sid
diff --git a/PKGBUILD b/PKGBUILD
index e3eeac87304c..182bf8890e34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,28 @@
_reponame=asid
pkgname=a-sid
-pkgver=1.0.2
+pkgver=1.0.3
pkgrel=1
pkgdesc="Emulation of the C64 MOS 8580 SID analog filter as a VST3 plugin"
arch=(x86_64)
url='https://www.orastron.com/asid'
license=(GPL3 MIT)
-depends=(glibc)
+depends=(glibc gcc-libs libxcb)
makedepends=(vst3sdk)
groups=(pro-audio vst3-plugins)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/sdangelo/$_reponame/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('76bf5e925b2aed577b2eea255cb3f972be6f4d5c3925898855eefdbdbfbad17d')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/sdangelo/$_reponame/archive/refs/tags/$pkgver.tar.gz"
+ 'a-sid-build-linux.patch')
+sha256sums=('16bd9df96d763dfba3add95e643b48713fb22401e6f54df57cceaf5793f65a55'
+ '0060a7758e066c83812b2f0c6944b7ca7c0f26e1226d271314507808b2b274f5')
prepare() {
- cd $_reponame-$pkgver/vst3
- sed -i -e 's|VST_SDK_DIR=.*$|VST_SDK_DIR=/usr/include|' buildLinux.sh
+ cd $_reponame-$pkgver
+ patch -p1 -N -r - -i "$srcdir"/a-sid-build-linux.patch
}
build() {
cd $_reponame-$pkgver/vst3
- ./buildLinux.sh
+ VST_SDK_DIR=/usr/include ./buildLinux.sh
}
package() {
diff --git a/a-sid-build-linux.patch b/a-sid-build-linux.patch
new file mode 100644
index 000000000000..939401ce7f1d
--- /dev/null
+++ b/a-sid-build-linux.patch
@@ -0,0 +1,23 @@
+diff --git a/vst3/buildLinux.sh b/vst3/buildLinux.sh
+index 299dab8..e2202d7 100755
+--- a/vst3/buildLinux.sh
++++ b/vst3/buildLinux.sh
+@@ -1,6 +1,6 @@
+ #!/bin/bash
+
+-VST_SDK_DIR=../../VST_SDK
++VST_SDK_DIR=${VST_SDK_DIR:-../../VST_SDK}
+
+ rm -rf build
+
+@@ -46,8 +46,7 @@ g++ \
+ -I../src \
+ -Isrc \
+ -I$VST_SDK_DIR/vst3sdk/ \
++ $(pkgconf --cflags --libs xcb) \
+ -fPIC -shared \
+- -static-libgcc \
+- -static-libstdc++ \
+ -o build/asid.vst3/Contents/x86_64-linux/asid.so \
+- -O3
++ ${CXXFLAGS:--O3} $LDFLAGS