summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOSAMC2022-10-05 20:36:02 +0000
committerChristopher Arndt2022-10-05 20:36:02 +0000
commit64a41f30a0406fcb3f07abd836f9afdfe2092e9f (patch)
tree201ce396f02538b4a046a0ae228582901ce29426
parent31f2ba65d3533f9b3794a152e988d70fca0dd024 (diff)
downloadaur-64a41f30a0406fcb3f07abd836f9afdfe2092e9f.tar.gz
feat: import package a-sid from AUR (#122)
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD14
-rw-r--r--a-sid-build-linux.patch15
4 files changed, 27 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f8ec279a73e..5c700b187a3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = a-sid
pkgdesc = Emulation of the C64 MOS 8580 SID analog filter as a VST3 plugin
pkgver = 1.0.3
- pkgrel = 1
+ pkgrel = 2
url = https://www.orastron.com/asid
arch = x86_64
+ arch = aarch64
groups = pro-audio
groups = vst3-plugins
license = GPL3
@@ -12,9 +13,10 @@ pkgbase = a-sid
depends = glibc
depends = gcc-libs
depends = libxcb
+ optdepends = vst3-host: for loading the VST3 plugin
source = a-sid-1.0.3.tar.gz::https://github.com/sdangelo/asid/archive/refs/tags/1.0.3.tar.gz
source = a-sid-build-linux.patch
sha256sums = 16bd9df96d763dfba3add95e643b48713fb22401e6f54df57cceaf5793f65a55
- sha256sums = 0060a7758e066c83812b2f0c6944b7ca7c0f26e1226d271314507808b2b274f5
+ sha256sums = bd21be0d58d33a126e95c61c70384f8ff63a0740b9d1c9f8752d84f6602d0f1d
pkgname = a-sid
diff --git a/.gitignore b/.gitignore
index 710dfc63e590..57e7fd90984f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-src/
pkg/
-a-sid-*.tar.gz
-a-sid-*.pkg.tar.*
+src/
+*.tar.*
+*.zip
diff --git a/PKGBUILD b/PKGBUILD
index 182bf8890e34..b7dd597fbb56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
-# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Maintainer: OSAMC <https://github.com/osam-cologne/archlinux-proaudio>
+# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
_reponame=asid
pkgname=a-sid
pkgver=1.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="Emulation of the C64 MOS 8580 SID analog filter as a VST3 plugin"
-arch=(x86_64)
+arch=(x86_64 aarch64)
url='https://www.orastron.com/asid'
license=(GPL3 MIT)
depends=(glibc gcc-libs libxcb)
makedepends=(vst3sdk)
+optdepends=('vst3-host: for loading the VST3 plugin')
groups=(pro-audio vst3-plugins)
source=("$pkgname-$pkgver.tar.gz::https://github.com/sdangelo/$_reponame/archive/refs/tags/$pkgver.tar.gz"
'a-sid-build-linux.patch')
sha256sums=('16bd9df96d763dfba3add95e643b48713fb22401e6f54df57cceaf5793f65a55'
- '0060a7758e066c83812b2f0c6944b7ca7c0f26e1226d271314507808b2b274f5')
+ 'bd21be0d58d33a126e95c61c70384f8ff63a0740b9d1c9f8752d84f6602d0f1d')
prepare() {
cd $_reponame-$pkgver
@@ -30,10 +32,10 @@ package() {
cd $_reponame-$pkgver
# plugin bundle
- install -Dm755 vst3/build/$_reponame.vst3/desktop.ini \
+ install -Dm644 vst3/build/$_reponame.vst3/desktop.ini \
vst3/build/$_reponame.vst3/Plugin.ico \
-t "$pkgdir"/usr/lib/vst3/$_reponame.vst3
- install -Dm755 vst3/build/$_reponame.vst3/Contents/Info.plist \
+ install -Dm644 vst3/build/$_reponame.vst3/Contents/Info.plist \
vst3/build/$_reponame.vst3/Contents/PkgInfo \
-t "$pkgdir"/usr/lib/vst3/$_reponame.vst3/Contents
install -Dm755 vst3/build/$_reponame.vst3/Contents/$(uname -m)-linux/$_reponame.so \
diff --git a/a-sid-build-linux.patch b/a-sid-build-linux.patch
index 939401ce7f1d..5fec434cd1e0 100644
--- a/a-sid-build-linux.patch
+++ b/a-sid-build-linux.patch
@@ -1,8 +1,8 @@
diff --git a/vst3/buildLinux.sh b/vst3/buildLinux.sh
-index 299dab8..e2202d7 100755
+index 299dab8..353926d 100755
--- a/vst3/buildLinux.sh
+++ b/vst3/buildLinux.sh
-@@ -1,6 +1,6 @@
+@@ -1,13 +1,13 @@
#!/bin/bash
-VST_SDK_DIR=../../VST_SDK
@@ -10,6 +10,14 @@ index 299dab8..e2202d7 100755
rm -rf build
+ mkdir -p build
+ cp -R asid.vst3 build
+
+-mkdir -p build/asid.vst3/Contents/x86_64-linux
++mkdir -p build/asid.vst3/Contents/$(uname -m)-linux
+
+ g++ \
+ src/vst3/entry.cpp \
@@ -46,8 +46,7 @@ g++ \
-I../src \
-Isrc \
@@ -18,6 +26,7 @@ index 299dab8..e2202d7 100755
-fPIC -shared \
- -static-libgcc \
- -static-libstdc++ \
- -o build/asid.vst3/Contents/x86_64-linux/asid.so \
+- -o build/asid.vst3/Contents/x86_64-linux/asid.so \
- -O3
++ -o build/asid.vst3/Contents/$(uname -m)-linux/asid.so \
+ ${CXXFLAGS:--O3} $LDFLAGS