summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOSAMC2022-10-14 17:54:03 +0000
committerChristopher Arndt2022-10-14 17:54:03 +0000
commitaa39b3d917d5ce141bbbe1336e2b928d582254fd (patch)
tree96fb53bf77f34ac39e01ae59f29b2f79609eff43
parent64a41f30a0406fcb3f07abd836f9afdfe2092e9f (diff)
downloadaur-aa39b3d917d5ce141bbbe1336e2b928d582254fd.tar.gz
feat: update package a-sid to 1.0.4 (#127)
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
-rw-r--r--a-sid-build-linux.patch43
3 files changed, 43 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c700b187a3a..88dcbee3fb08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = a-sid
pkgdesc = Emulation of the C64 MOS 8580 SID analog filter as a VST3 plugin
- pkgver = 1.0.3
- pkgrel = 2
+ pkgver = 1.0.4
+ pkgrel = 1
url = https://www.orastron.com/asid
arch = x86_64
arch = aarch64
@@ -14,9 +14,9 @@ pkgbase = a-sid
depends = gcc-libs
depends = libxcb
optdepends = vst3-host: for loading the VST3 plugin
- source = a-sid-1.0.3.tar.gz::https://github.com/sdangelo/asid/archive/refs/tags/1.0.3.tar.gz
+ source = a-sid-1.0.4.tar.gz::https://github.com/sdangelo/asid/archive/refs/tags/1.0.4.tar.gz
source = a-sid-build-linux.patch
- sha256sums = 16bd9df96d763dfba3add95e643b48713fb22401e6f54df57cceaf5793f65a55
- sha256sums = bd21be0d58d33a126e95c61c70384f8ff63a0740b9d1c9f8752d84f6602d0f1d
+ sha256sums = 43714a84e3512767d5cc99335a90a04ab689ebe9a4a5f309e0a512f1cdee0c76
+ sha256sums = 47fe561a94a7553538d27e7a738beb5e6d62f552985df2ef24e9db81c58b0168
pkgname = a-sid
diff --git a/PKGBUILD b/PKGBUILD
index b7dd597fbb56..b7a99abd243a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_reponame=asid
pkgname=a-sid
-pkgver=1.0.3
-pkgrel=2
+pkgver=1.0.4
+pkgrel=1
pkgdesc="Emulation of the C64 MOS 8580 SID analog filter as a VST3 plugin"
arch=(x86_64 aarch64)
url='https://www.orastron.com/asid'
@@ -15,8 +15,8 @@ optdepends=('vst3-host: for loading the VST3 plugin')
groups=(pro-audio vst3-plugins)
source=("$pkgname-$pkgver.tar.gz::https://github.com/sdangelo/$_reponame/archive/refs/tags/$pkgver.tar.gz"
'a-sid-build-linux.patch')
-sha256sums=('16bd9df96d763dfba3add95e643b48713fb22401e6f54df57cceaf5793f65a55'
- 'bd21be0d58d33a126e95c61c70384f8ff63a0740b9d1c9f8752d84f6602d0f1d')
+sha256sums=('43714a84e3512767d5cc99335a90a04ab689ebe9a4a5f309e0a512f1cdee0c76'
+ '47fe561a94a7553538d27e7a738beb5e6d62f552985df2ef24e9db81c58b0168')
prepare() {
cd $_reponame-$pkgver
@@ -25,19 +25,16 @@ prepare() {
build() {
cd $_reponame-$pkgver/vst3
- VST_SDK_DIR=/usr/include ./buildLinux.sh
+ if [[ -d /usr/share/vst3sdk ]]; then
+ VST_SDK_DIR=/usr/share ./buildLinux.sh
+ else
+ VST_SDK_DIR=/usr/include ./buildLinux.sh
+ fi
}
package() {
cd $_reponame-$pkgver
-
# plugin bundle
- install -Dm644 vst3/build/$_reponame.vst3/desktop.ini \
- vst3/build/$_reponame.vst3/Plugin.ico \
- -t "$pkgdir"/usr/lib/vst3/$_reponame.vst3
- install -Dm644 vst3/build/$_reponame.vst3/Contents/Info.plist \
- vst3/build/$_reponame.vst3/Contents/PkgInfo \
- -t "$pkgdir"/usr/lib/vst3/$_reponame.vst3/Contents
install -Dm755 vst3/build/$_reponame.vst3/Contents/$(uname -m)-linux/$_reponame.so \
-t "$pkgdir"/usr/lib/vst3/$_reponame.vst3/Contents/$(uname -m)-linux
# documentation
diff --git a/a-sid-build-linux.patch b/a-sid-build-linux.patch
index 5fec434cd1e0..3fc1428ac070 100644
--- a/a-sid-build-linux.patch
+++ b/a-sid-build-linux.patch
@@ -1,32 +1,47 @@
diff --git a/vst3/buildLinux.sh b/vst3/buildLinux.sh
-index 299dab8..353926d 100755
+index 647969a..2ac4034 100755
--- a/vst3/buildLinux.sh
+++ b/vst3/buildLinux.sh
-@@ -1,13 +1,13 @@
+@@ -1,15 +1,19 @@
#!/bin/bash
-VST_SDK_DIR=../../VST_SDK
-+VST_SDK_DIR=${VST_SDK_DIR:-../../VST_SDK}
++VST_SDK_DIR="${VST_SDK_DIR:-../../VST_SDK}"
rm -rf build
- mkdir -p build
- cp -R asid.vst3 build
+ mkdir -p build/asid.vst3/Contents
+ cp -R asid.vst3/Contents/Resources build/asid.vst3/Contents
-mkdir -p build/asid.vst3/Contents/x86_64-linux
+mkdir -p build/asid.vst3/Contents/$(uname -m)-linux
g++ \
++ -DRELEASE=1 \
++ -I../src \
++ -Isrc \
++ -I$VST_SDK_DIR/vst3sdk/ \
src/vst3/entry.cpp \
-@@ -46,8 +46,7 @@ g++ \
- -I../src \
- -Isrc \
- -I$VST_SDK_DIR/vst3sdk/ \
-+ $(pkgconf --cflags --libs xcb) \
+ src/vst3/plugin.cpp \
+ src/vst3/controllerLinux.cpp \
+@@ -42,16 +46,11 @@ g++ \
+ src/asid_gui.c \
+ src/gui-x.c \
+ \
+- -DRELEASE=1 \
+- -I../src \
+- -Isrc \
+- -I$VST_SDK_DIR/vst3sdk/ \
-fPIC -shared \
-- -static-libgcc \
-- -static-libstdc++ \
+- -lxcb \
- -o build/asid.vst3/Contents/x86_64-linux/asid.so \
-- -O3
+- -O3 \
+- -ffast-math
+-
++ $(pkg-config --cflags --libs xcb) \
+ -o build/asid.vst3/Contents/$(uname -m)-linux/asid.so \
-+ ${CXXFLAGS:--O3} $LDFLAGS
++ ${CXXFLAGS:--O3 -ffast-math} $LDFLAGS
++
+ # for a more static build we probably need
+ # -static-libgcc -static-libstdc++ -l:library.a...
+ # with static libraries built with -fPIC