summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2022-09-23 17:17:58 +0200
committerChristopher Arndt2022-09-23 17:17:58 +0200
commitfcd3e5fc0b91767a9d5a82b95844dc05a0885a21 (patch)
tree9931b70492636f816dd9f6dfeb87f62039d2d9e1
downloadaur-fcd3e5fc0b91767a9d5a82b95844dc05a0885a21.tar.gz
Add new package 'a-sid'
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD45
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1f94fdd7d80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = a-sid
+ pkgdesc = Emulation of the C64 MOS 8580 SID analog filter as a VST3 plugin
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://www.orastron.com/asid
+ arch = x86_64
+ groups = pro-audio
+ groups = vst3-plugins
+ license = GPL3
+ license = MIT
+ makedepends = vst3sdk
+ depends = glibc
+ source = a-sid-1.0.2.tar.gz::https://github.com/sdangelo/asid/archive/refs/tags/1.0.2.tar.gz
+ sha256sums = 76bf5e925b2aed577b2eea255cb3f972be6f4d5c3925898855eefdbdbfbad17d
+
+pkgname = a-sid
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..710dfc63e590
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+a-sid-*.tar.gz
+a-sid-*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3eeac87304c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_reponame=asid
+pkgname=a-sid
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Emulation of the C64 MOS 8580 SID analog filter as a VST3 plugin"
+arch=(x86_64)
+url='https://www.orastron.com/asid'
+license=(GPL3 MIT)
+depends=(glibc)
+makedepends=(vst3sdk)
+groups=(pro-audio vst3-plugins)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/sdangelo/$_reponame/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('76bf5e925b2aed577b2eea255cb3f972be6f4d5c3925898855eefdbdbfbad17d')
+
+prepare() {
+ cd $_reponame-$pkgver/vst3
+ sed -i -e 's|VST_SDK_DIR=.*$|VST_SDK_DIR=/usr/include|' buildLinux.sh
+}
+
+build() {
+ cd $_reponame-$pkgver/vst3
+ ./buildLinux.sh
+}
+
+package() {
+ cd $_reponame-$pkgver
+
+ # plugin bundle
+ install -Dm755 vst3/build/$_reponame.vst3/desktop.ini \
+ vst3/build/$_reponame.vst3/Plugin.ico \
+ -t "$pkgdir"/usr/lib/vst3/$_reponame.vst3
+ install -Dm755 vst3/build/$_reponame.vst3/Contents/Info.plist \
+ vst3/build/$_reponame.vst3/Contents/PkgInfo \
+ -t "$pkgdir"/usr/lib/vst3/$_reponame.vst3/Contents
+ install -Dm755 vst3/build/$_reponame.vst3/Contents/$(uname -m)-linux/$_reponame.so \
+ -t "$pkgdir"/usr/lib/vst3/$_reponame.vst3/Contents/$(uname -m)-linux
+ # documentation
+ install -Dm644 README.md vst3/$_reponame.vst3/Contents/Resources/ChangeLog.txt -t \
+ "$pkgdir"/usr/share/doc/$pkgname
+ # extra license
+ install -Dm644 vst3/$_reponame.vst3/Contents/Resources/sse2neon-license.txt -t \
+ "$pkgdir"/usr/share/licenses/$pkgname
+}