summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChrister Solskogen2022-03-12 11:22:13 +0100
committerChrister Solskogen2022-03-12 11:22:13 +0100
commit316cd58853fb4d4fdea8ee18a9d6825b0eebe358 (patch)
tree298a1cb94cdb65e8fb7dfa3cd929d5245c14bde5
parentb049e0ecad8def33f64ef54ef27e67f3f585b1af (diff)
downloadaur-316cd58853fb4d4fdea8ee18a9d6825b0eebe358.tar.gz
Align more with Arch Linux ARM
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD54
2 files changed, 26 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d172f8d5fc59..db36fa96a781 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aarch64-binutils
pkgdesc = A set of programs to assemble and manipulate binary and object files for the ARM64 target
pkgver = 2.37
- pkgrel = 1
+ pkgrel = 2
url = https://www.gnu.org/software/binutils/
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 9ca4e1f9df6c..780b15e70834 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _arch=aarch64
_target=$_arch-unknown-linux-gnu
pkgname=$_arch-binutils
pkgver=2.37
-pkgrel=1
+pkgrel=2
pkgdesc='A set of programs to assemble and manipulate binary and object files for the ARM64 target'
arch=('x86_64')
url='https://www.gnu.org/software/binutils/'
@@ -16,44 +16,40 @@ sha256sums=('820d9724f020a3e69cb337893a0b63c2db161dadcb0e06fc11dc29eb1e84a32c'
'SKIP')
validpgpkeys=(3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F)
-prepare() {
- cd binutils-$pkgver
-}
-
build() {
cd binutils-$pkgver
- ./configure --target=$_target \
- --with-sysroot=/usr/$_target/sys-root \
- --prefix=/usr \
- --disable-multilib \
- --disable-nls \
- --enable-gold \
- --enable-plugins \
- --enable-deterministic-archives \
- --enable-relro \
- --with-pic \
- --with-system-zlib
+ ./configure \
+ --target=$_target \
+ --with-sysroot=/usr/$_target/sys-root \
+ --prefix=/usr \
+ --enable-deterministic-archives \
+ --enable-gold \
+ --enable-install-libiberty \
+ --enable-ld=default \
+ --enable-lto \
+ --enable-plugins \
+ --enable-relro \
+ --enable-shared \
+ --enable-threads \
+ --disable-gdb \
+ --disable-gdbserver \
+ --disable-libdecnumber \
+ --disable-readline \
+ --disable-sim \
+ --disable-werror \
+ --with-debuginfod \
+ --with-pic \
+ --with-system-zlib
make
}
-check() {
- cd binutils-$pkgver
- make -k check || true
-}
-
package() {
cd binutils-$pkgver
make DESTDIR="$pkgdir" install
- # Remove file conflicting with host binutils and manpages for MS Windows tools
- rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,windres,windmc}*
-
- # Remove info documents that conflict with host version
- rm -r "$pkgdir"/usr/share/info
-
- #Remove .so that conflict with host version
- rm -r "$pkgdir"/usr/lib
+ # Remove files that conflict with host version
+ rm -r "$pkgdir"/usr/{include,lib,share}
}