summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChrister Solskogen2021-02-10 13:45:08 +0100
committerChrister Solskogen2021-02-10 13:45:08 +0100
commit37349c237eb01e4933647888dc36d487e790d7a4 (patch)
treec1286df1e7866a824bcdd79ec37713282c837368
downloadaur-37349c237eb01e4933647888dc36d487e790d7a4.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD70
2 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb415f7f9ff1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = aarch64-binutils
+ pkgdesc = A set of programs to assemble and manipulate binary and object files for the ARM64 target
+ pkgver = 2.36.1
+ pkgrel = 1
+ url = https://www.gnu.org/software/binutils/
+ arch = x86_64
+ license = GPL
+ depends = libelf
+ source = https://ftp.gnu.org/gnu/binutils/binutils-2.36.1.tar.xz
+ source = https://ftp.gnu.org/gnu/binutils/binutils-2.36.1.tar.xz.sig
+ validpgpkeys = EAF1C276A747E9ED86210CBAC3126D3B4AE55E93
+ validpgpkeys = 3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F
+ sha256sums = e81d9edf373f193af428a0f256674aea62a9d74dfe93f65192d4eae030b0f3b0
+ sha256sums = SKIP
+
+pkgname = aarch64-binutils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfd88d5e670d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
+# Contributor: Christer Solskogen <christer.solskogen@gmail.com>
+# Build order: aarch64-binutils -> aarch64-linux-api-headers -> aarch64-gcc-bootstrap -> aarch64-glibc -> aarch64-gcc -> aarch64-glibc (again)
+
+_arch=aarch64
+_target=$_arch-unknown-linux-gnu
+pkgname=$_arch-binutils
+pkgver=2.36.1
+pkgrel=1
+pkgdesc='A set of programs to assemble and manipulate binary and object files for the ARM64 target'
+arch=(x86_64)
+url='https://www.gnu.org/software/binutils/'
+license=(GPL)
+depends=('libelf')
+source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.xz{,.sig})
+sha256sums=('e81d9edf373f193af428a0f256674aea62a9d74dfe93f65192d4eae030b0f3b0'
+ 'SKIP')
+validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93' # Tristan Gingold <gingold@adacore.com>
+ '3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F') # Nick Clifton (Chief Binutils Maintainer) <nickc@redhat.com>
+
+prepare() {
+ cd binutils-$pkgver
+ sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
+}
+
+build() {
+ cd binutils-$pkgver
+
+ ./configure --target=$_target \
+ --with-sysroot=/usr/$_target/sys-root \
+ --prefix=/usr \
+ --disable-multilib \
+ --disable-nls \
+ --enable-ld=default \
+ --enable-gold \
+ --enable-plugins \
+ --enable-deterministic-archives \
+ --enable-relro \
+ --with-pic \
+ --with-system-zlib
+
+ make
+}
+
+check() {
+ cd binutils-$pkgver
+ make
+}
+
+package() {
+ cd binutils-$pkgver
+
+ make DESTDIR="$pkgdir" install
+
+ # Replace hard links with symlinks
+ for file in $(ls "$pkgdir"/usr/$_target/bin)
+ do
+ rm "$pkgdir"/usr/$_target/bin/$file
+ ln -sv ../../bin/$_target-$file "$pkgdir"/usr/$_target/bin/$file
+ done
+
+ # Remove file conflicting with host binutils and manpages for MS Windows tools
+ rm "$pkgdir"/usr/share/man/man1/$_target-{dlltool,windres,windmc}*
+
+ # Remove info documents that conflict with host version
+ rm -r "$pkgdir"/usr/share/info
+
+ #Remove .so that conflict with host version
+ rm -r "$pkgdir"/usr/lib
+}