summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzargbell2017-09-09 22:21:39 +0300
committerzargbell2017-09-09 22:21:39 +0300
commit832789f4108b36ae2e56b411d499e6211fccf0b4 (patch)
tree683fc8f8612f53980c51ac2d93ecb48e29f5b362
downloadaur-832789f4108b36ae2e56b411d499e6211fccf0b4.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0706ba15706a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = aarch64-elf-gcc-linaro-bin
+ pkgdesc = The GNU Compiler Collection - cross compiler for ARM64 EABI (bare-metal) target.
+ pkgver = 7.1
+ pkgrel = 1
+ url = http://www.linaro.org/downloads/
+ arch = x86_64
+ groups = aarch64-elf-linaro-toolchain-bin
+ license = GPL
+ license = LGPL
+ optdepends = aarch64-elf-newlib-linaro-bin: Standard C library optimized for embedded systems
+ options = !emptydirs
+ options = !strip
+ options = staticlibs
+ source = http://releases.linaro.org/components/toolchain/binaries/7.1-2017.08/aarch64-elf/gcc-linaro-7.1.1-2017.08-x86_64_aarch64-elf.tar.xz
+ sha512sums = 28031d413573e3c617b29a516625fe086db9a4d1922ac78682128a5a17d5c5c6de1c93d24394c8e8b50d98bb69fb2811706515be793c64aa0bee3d75183c4b92
+
+pkgname = aarch64-elf-gcc-linaro-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87f517499c29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: zargbell <zargbell@yandex.ru>
+
+_target=aarch64-elf
+_pkgdate=2017.08
+
+
+pkgname=${_target}-gcc-linaro-bin
+pkgver=7.1
+pkgrel=1
+epoch=
+pkgdesc="The GNU Compiler Collection - cross compiler for ARM64 EABI (bare-metal) target."
+arch=('x86_64')
+url="http://www.linaro.org/downloads/"
+license=('GPL' 'LGPL')
+groups=(${_target}-linaro-toolchain-bin)
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=("${_target}-newlib-linaro-bin: Standard C library optimized for embedded systems")
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs !strip staticlibs)
+install=
+changelog=
+source=(http://releases.linaro.org/components/toolchain/binaries/${pkgver}-${_pkgdate}/${_target}/gcc-linaro-${pkgver}.1-${_pkgdate}-x86_64_${_target}.tar.xz)
+sha512sums=('28031d413573e3c617b29a516625fe086db9a4d1922ac78682128a5a17d5c5c6de1c93d24394c8e8b50d98bb69fb2811706515be793c64aa0bee3d75183c4b92')
+
+
+package() {
+ mkdir -p ${pkgdir}/usr
+ cp -a ${srcdir}/gcc-linaro-${pkgver}.1-${_pkgdate}-x86_64_${_target}/* ${pkgdir}/usr
+
+ rm -f ${pkgdir}/usr/*-manifest.txt
+ rm -f ${pkgdir}/usr/bin/runtest
+ rm -f ${pkgdir}/usr/lib/lib*
+ rm -rf ${pkgdir}/usr/include
+ rm -rf ${pkgdir}/usr/share/{dejagnu,doc,gcc-*,gdb,info,locale}
+ rm -rf ${pkgdir}/usr/share/man/{man1/runtest.1,man5,man7}
+}