summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChrister Solskogen2023-01-07 13:33:35 +0000
committerChrister Solskogen2023-01-07 13:33:35 +0000
commit0a41a7a68f9b3437c89542f624197dddbd08b662 (patch)
treef88ae281e18e7eb449cb26a8f435e4f19f982867
parent6fb47ad13ac0be0f67c04b601df667f7efd5e60c (diff)
downloadaur-0a41a7a68f9b3437c89542f624197dddbd08b662.tar.gz
switch to using git and align with ALARM
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c719b75d863..00cd5a4f615b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aarch64-gcc-bootstrap
pkgdesc = The GNU Compiler Collection - cross compiler for ARM64 target - bootstrap compiler
- pkgver = 12.2.0
- pkgrel = 1
+ pkgver = 12.2.1
+ pkgrel = 2
url = https://gcc.gnu.org/
arch = x86_64
license = GPL
@@ -16,13 +16,11 @@ pkgbase = aarch64-gcc-bootstrap
options = !emptydirs
options = !strip
options = staticlibs
- source = https://sourceware.org/pub/gcc/releases/gcc-12.2.0/gcc-12.2.0.tar.xz
- source = https://sourceware.org/pub/gcc/releases/gcc-12.2.0/gcc-12.2.0.tar.xz.sig
+ source = git+https://sourceware.org/git/gcc.git#commit=6b1adeb22789e190e87b905761f8a47a2e4e830a
validpgpkeys = F3691687D867B81B51CE07D9BBE43771487328A9
validpgpkeys = 86CFFCA918CF3AF47147588051E8B148A9999C34
validpgpkeys = 13975A70E63C361C73AE69EF6EEB81F8981C74C7
validpgpkeys = D3A93CAD751C2AF4F8C7AD516C35B99309B5FA62
- sha256sums = e549cf9cf3594a00e27b6589d4322d70e0720cdd213f39beb4181e06926230ff
sha256sums = SKIP
pkgname = aarch64-gcc-bootstrap
diff --git a/PKGBUILD b/PKGBUILD
index 21149baec9fe..e4d7d8984632 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
_arch=aarch64
_target=$_arch-unknown-linux-gnu
pkgname=$_arch-gcc-bootstrap
-pkgver=12.2.0
-pkgrel=1
+pkgver=12.2.1
+pkgrel=2
pkgdesc='The GNU Compiler Collection - cross compiler for ARM64 target - bootstrap compiler'
arch=(x86_64)
url='https://gcc.gnu.org/'
@@ -15,11 +15,10 @@ makedepends=($_arch-binutils)
provides=($_arch-gcc)
conflicts=($_arch-gcc)
options=(!emptydirs !strip staticlibs)
-_commit=908e612067e42ded881db10d38768f23307bf55e
-source=(https://sourceware.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz{,.sig})
+_commit=6b1adeb22789e190e87b905761f8a47a2e4e830a
+source=(git+https://sourceware.org/git/gcc.git#commit=${_commit})
-sha256sums=('e549cf9cf3594a00e27b6589d4322d70e0720cdd213f39beb4181e06926230ff'
- 'SKIP')
+sha256sums=('SKIP')
validpgpkeys=(F3691687D867B81B51CE07D9BBE43771487328A9 # bpiotrowski@archlinux.org
86CFFCA918CF3AF47147588051E8B148A9999C34 # evangelos@foutrelis.com
@@ -43,7 +42,7 @@ build() {
CFLAGS=${CFLAGS/-Werror=format-security/}
CXXFLAGS=${CXXFLAGS/-Werror=format-security/}
- "$srcdir"/gcc-$pkgver/configure \
+ "$srcdir"/gcc/configure \
--prefix=/usr \
--with-sysroot=/usr/$_target/sys-root \
--libexecdir=/usr/lib \
@@ -53,7 +52,7 @@ build() {
--with-system-zlib \
--disable-multilib --disable-werror \
--disable-threads --without-headers \
- --disable-shared --with-newlib
+ --disable-shared --with-newlib --with-arch=armv8-a
make all-gcc all-target-libgcc
}