summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChrister Solskogen2022-03-12 13:19:39 +0100
committerChrister Solskogen2022-03-12 13:19:39 +0100
commit1b2f3a6dfe3f5411a7b959c2176a021fc5561fd3 (patch)
treeffed54882bec7b28ac82855ceeded4e55b3488e7
parent98e9f529ade668b7621ec7a176ee525ccca800fd (diff)
downloadaur-1b2f3a6dfe3f5411a7b959c2176a021fc5561fd3.tar.gz
simplify
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD34
2 files changed, 13 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5a437f00248..901621040b15 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aarch64-gcc-bootstrap
pkgdesc = The GNU Compiler Collection - cross compiler for ARM64 target - bootstrap compiler
pkgver = 11.2.0
- pkgrel = 1
+ pkgrel = 4
url = https://gcc.gnu.org/
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index b9110f899df9..d0f62867de33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,7 @@ _arch=aarch64
_target=$_arch-unknown-linux-gnu
pkgname=$_arch-gcc-bootstrap
pkgver=11.2.0
-pkgrel=1
-#_snapshot=8-20190111
+pkgrel=4
pkgdesc='The GNU Compiler Collection - cross compiler for ARM64 target - bootstrap compiler'
arch=(x86_64)
url='https://gcc.gnu.org/'
@@ -16,6 +15,7 @@ makedepends=($_arch-binutils)
provides=($_arch-gcc)
conflicts=($_arch-gcc)
options=(!emptydirs !strip staticlibs)
+_commit=908e612067e42ded881db10d38768f23307bf55e
source=(https://sourceware.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz{,.sig})
sha256sums=('d08edc536b54c372a1010ff6619dd274c0f1603aa49212ba20f7aa2cda36fa8b'
@@ -26,15 +26,9 @@ validpgpkeys=(F3691687D867B81B51CE07D9BBE43771487328A9 # bpiotrowski@archlinux.
13975A70E63C361C73AE69EF6EEB81F8981C74C7 # richard.guenther@gmail.com
D3A93CAD751C2AF4F8C7AD516C35B99309B5FA62) # Jakub Jelinek <jakub@redhat.com>
-if [ -n "$_snapshot" ]; then
- _basedir=gcc-$_snapshot
-else
- _basedir=gcc-$pkgver
-fi
-
prepare() {
- cd $_basedir
-
+ [[ ! -d gcc ]] && ln -s gcc-${pkgver/+/-} gcc
+ cd gcc
rm -rf "$srcdir"/gcc-build
mkdir "$srcdir"/gcc-build
@@ -42,26 +36,23 @@ prepare() {
build() {
cd gcc-build
-
+
+ # Credits @allanmcrae
+ # https://github.com/allanmcrae/toolchain/blob/f18604d70c5933c31b51a320978711e4e6791cf1/gcc/PKGBUILD
+ # TODO: properly deal with the build issues resulting from this
CFLAGS=${CFLAGS/-Werror=format-security/}
CXXFLAGS=${CXXFLAGS/-Werror=format-security/}
- "$srcdir"/$_basedir/configure \
+ "$srcdir"/gcc-$pkgver/configure \
--prefix=/usr \
--with-sysroot=/usr/$_target/sys-root \
--libexecdir=/usr/lib \
--target=$_target \
- --disable-nls --enable-default-pie \
+ --disable-nls \
--enable-languages=c \
- --with-system-zlib --enable-__cxa_atexit \
- --enable-linker-build-id \
- --enable-plugin \
- --with-linker-hash-style=gnu --enable-gnu-indirect-function \
+ --with-system-zlib \
--disable-multilib --disable-werror \
- --enable-checking=release --enable-host-shared \
- --with-arch=armv8-a \
- --enable-fix-cortex-a53-835769 --enable-fix-cortex-a53-843419 \
- --disable-threads --without-headers --with-glibc-version=2.35 \
+ --disable-threads --without-headers \
--disable-shared --with-newlib
make all-gcc all-target-libgcc
@@ -71,7 +62,6 @@ package() {
cd gcc-build
make install-strip-gcc install-strip-target-libgcc DESTDIR="$pkgdir"
- ln -s $_target-gcc "$pkgdir"/usr/bin/$_target-cc
# Remove files that conflict with host gcc package
rm -r "$pkgdir"/usr/{include,share}