summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChrister Solskogen2022-03-12 11:29:55 +0100
committerChrister Solskogen2022-03-12 11:29:55 +0100
commit98e9f529ade668b7621ec7a176ee525ccca800fd (patch)
treede2fc82ac9f757438e908e8b1e87ab654e0e303e
parent75bbeca62fa5540540c139442a6828dfc8bba495 (diff)
downloadaur-98e9f529ade668b7621ec7a176ee525ccca800fd.tar.gz
small fixes
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD29
2 files changed, 13 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f36d29052b4..f5a437f00248 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aarch64-gcc-bootstrap
pkgdesc = The GNU Compiler Collection - cross compiler for ARM64 target - bootstrap compiler
pkgver = 11.2.0
- pkgrel = 0
+ pkgrel = 1
url = https://gcc.gnu.org/
arch = x86_64
license = GPL
@@ -10,6 +10,7 @@ pkgbase = aarch64-gcc-bootstrap
makedepends = aarch64-binutils
depends = libmpc
depends = zstd
+ depends = libisl
provides = aarch64-gcc
conflicts = aarch64-gcc
options = !emptydirs
@@ -17,13 +18,11 @@ pkgbase = aarch64-gcc-bootstrap
options = staticlibs
source = https://sourceware.org/pub/gcc/releases/gcc-11.2.0/gcc-11.2.0.tar.xz
source = https://sourceware.org/pub/gcc/releases/gcc-11.2.0/gcc-11.2.0.tar.xz.sig
- source = https://libisl.sourceforge.io/isl-0.24.tar.xz
validpgpkeys = F3691687D867B81B51CE07D9BBE43771487328A9
validpgpkeys = 86CFFCA918CF3AF47147588051E8B148A9999C34
validpgpkeys = 13975A70E63C361C73AE69EF6EEB81F8981C74C7
validpgpkeys = D3A93CAD751C2AF4F8C7AD516C35B99309B5FA62
sha256sums = d08edc536b54c372a1010ff6619dd274c0f1603aa49212ba20f7aa2cda36fa8b
sha256sums = SKIP
- sha256sums = 043105cc544f416b48736fff8caf077fb0663a717d06b1113f16e391ac99ebad
pkgname = aarch64-gcc-bootstrap
diff --git a/PKGBUILD b/PKGBUILD
index 314bc834d67a..b9110f899df9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,26 @@
-# Maintainer: Anatol Pomozov <anatol.pomozov@gmail.com>
-# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
-# Contributor: Christer Solskogen <christer.solskogen@gmail.com>
+# Maintainer: Christer Solskogen <christer.solskogen@gmail.com>
# Build order: aarch64-binutils -> aarch64-linux-api-headers -> aarch64-gcc-bootstrap -> aarch64-glibc -> aarch64-gcc -> aarch64-glibc (again)
_arch=aarch64
_target=$_arch-unknown-linux-gnu
pkgname=$_arch-gcc-bootstrap
pkgver=11.2.0
-_islver=0.24
-pkgrel=0
+pkgrel=1
#_snapshot=8-20190111
pkgdesc='The GNU Compiler Collection - cross compiler for ARM64 target - bootstrap compiler'
arch=(x86_64)
url='https://gcc.gnu.org/'
license=(GPL LGPL FDL)
-depends=(libmpc zstd)
+depends=(libmpc zstd libisl)
makedepends=($_arch-binutils)
provides=($_arch-gcc)
conflicts=($_arch-gcc)
options=(!emptydirs !strip staticlibs)
-source=(https://sourceware.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz{,.sig}
- "https://libisl.sourceforge.io/isl-${_islver}.tar.xz"
-)
+source=(https://sourceware.org/pub/gcc/releases/gcc-${pkgver}/gcc-${pkgver}.tar.xz{,.sig})
sha256sums=('d08edc536b54c372a1010ff6619dd274c0f1603aa49212ba20f7aa2cda36fa8b'
- 'SKIP'
- '043105cc544f416b48736fff8caf077fb0663a717d06b1113f16e391ac99ebad')
+ 'SKIP')
+
validpgpkeys=(F3691687D867B81B51CE07D9BBE43771487328A9 # bpiotrowski@archlinux.org
86CFFCA918CF3AF47147588051E8B148A9999C34 # evangelos@foutrelis.com
13975A70E63C361C73AE69EF6EEB81F8981C74C7 # richard.guenther@gmail.com
@@ -40,8 +35,6 @@ fi
prepare() {
cd $_basedir
- # link isl for in-tree builds
- ln -sf ../isl-$_islver isl
rm -rf "$srcdir"/gcc-build
mkdir "$srcdir"/gcc-build
@@ -49,7 +42,7 @@ prepare() {
build() {
cd gcc-build
-
+
CFLAGS=${CFLAGS/-Werror=format-security/}
CXXFLAGS=${CXXFLAGS/-Werror=format-security/}
@@ -59,16 +52,16 @@ build() {
--libexecdir=/usr/lib \
--target=$_target \
--disable-nls --enable-default-pie \
- --enable-languages=c,c++ \
- --with-system-zlib --with-isl --enable-__cxa_atexit \
+ --enable-languages=c \
+ --with-system-zlib --enable-__cxa_atexit \
--enable-linker-build-id \
--enable-plugin \
--with-linker-hash-style=gnu --enable-gnu-indirect-function \
--disable-multilib --disable-werror \
--enable-checking=release --enable-host-shared \
- --with-arch=armv8-a \
+ --with-arch=armv8-a \
--enable-fix-cortex-a53-835769 --enable-fix-cortex-a53-843419 \
- --disable-threads --without-headers --with-glibc-version=2.33 \
+ --disable-threads --without-headers --with-glibc-version=2.35 \
--disable-shared --with-newlib
make all-gcc all-target-libgcc