summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChrister Solskogen2021-08-03 14:59:02 +0200
committerChrister Solskogen2021-08-03 14:59:02 +0200
commita5eee741c4727ec89e0b63f3192aeb43128703f7 (patch)
treeedecaf0e6e4cc9d3da9d7100175186a0f511cb73
parent70af8dfbbd44d5b2e5462e0217f14ac49815b659 (diff)
downloadaur-a5eee741c4727ec89e0b63f3192aeb43128703f7.tar.gz
Workaround
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59c2aa94891d..72e654a6cdd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -62,6 +62,6 @@ package() {
#strip manually
find "$pkgdir"/usr/$_target/sys-root -name '*.so' -and ! -name 'libc.so' -print0 | xargs -0 $_target-strip --strip-all
- #workaround for fakeroot bug
- chown -R root:root "$pkgdir"/usr
+ #fix missing symlink
+ ln -s libpthread.so.0 "$pkgdir"/usr/$_target/sys-root/usr/lib/libpthread.so
}