summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChrister Solskogen2023-01-07 11:06:16 +0000
committerChrister Solskogen2023-01-07 11:06:16 +0000
commitefc17b245aa4bc9ab76b39ae31550aeb5d2d9515 (patch)
tree76cb33122d09b749f76833c43b0285f70887d884
parentfb9e32127e092e2d8933a041c1bf6fd497effa3a (diff)
downloadaur-efc17b245aa4bc9ab76b39ae31550aeb5d2d9515.tar.gz
switch to using git, and align a bit more with ALARM
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b23f19995d4..f92f24614962 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,16 +6,15 @@ pkgbase = aarch64-glibc
arch = any
license = GPL
license = LGPL
+ makedepends = git
makedepends = aarch64-gcc
makedepends = aarch64-linux-api-headers
makedepends = python
options = !strip
options = staticlibs
- source = https://ftp.gnu.org/gnu/libc/glibc-2.36.tar.xz
- source = https://ftp.gnu.org/gnu/libc/glibc-2.36.tar.xz.sig
+ source = git+https://sourceware.org/git/glibc.git#commit=4f4d7a13edfd2fdc57c9d76e1fd6d017fb47550c
validpgpkeys = 7273542B39962DF7B299931416792B4EA25340F8
validpgpkeys = BC7C7372637EC10C57D7AA6579C43DFBF1CF2187
- sha256sums = 1c959fea240906226062cb4b1e7ebce71a9f0e3c0836c09e7e3423d434fcfe75
- sha256sums = SKIP
+ b2sums = SKIP
pkgname = aarch64-glibc
diff --git a/PKGBUILD b/PKGBUILD
index a414238e5082..7a9885efb0aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,19 +6,19 @@ _target=$_arch-unknown-linux-gnu
pkgname=$_arch-glibc
pkgver=2.36
pkgrel=2
-_commit=be176490b818b65b5162c332eb6b581690b16e5c
+_commit=4f4d7a13edfd2fdc57c9d76e1fd6d017fb47550c
pkgdesc="GNU C Library ARM64 target"
arch=(any)
url='https://www.gnu.org/software/libc/'
license=('GPL' 'LGPL')
depends=()
-makedepends=($_arch-gcc $_arch-linux-api-headers python)
+makedepends=(git $_arch-gcc $_arch-linux-api-headers python)
options=(!strip staticlibs)
-source=(https://ftp.gnu.org/gnu/libc/glibc-$pkgver.tar.xz{,.sig})
-sha256sums=('1c959fea240906226062cb4b1e7ebce71a9f0e3c0836c09e7e3423d434fcfe75'
- 'SKIP')
+source=(git+https://sourceware.org/git/glibc.git#commit=${_commit})
+
validpgpkeys=(7273542B39962DF7B299931416792B4EA25340F8 # "Carlos O'Donell <carlos@systemhalted.org>"
BC7C7372637EC10C57D7AA6579C43DFBF1CF2187) # Siddhesh Poyarekar
+b2sums=('SKIP')
prepare() {
mkdir -p glibc-build
@@ -35,29 +35,28 @@ build() {
CFLAGS="-march=armv8-a -O2 -pipe -fstack-protector-strong -fno-plt -fexceptions \
-Wformat -Werror=format-security \
-fstack-clash-protection"
+CXXFLAGS="$CFLAGS -Wp,-D_GLIBCXX_ASSERTIONS"
- ../glibc-$pkgver/configure \
+ ../glibc/configure \
--prefix=/usr \
--host=$_target \
--libdir=/usr/lib \
--with-bugurl=https://aur.archlinux.org/packages/aarch64-glibc \
--enable-kernel=5.10 \
- --enable-add-ons \
--enable-bind-now \
- --enable-lock-elision \
--disable-multi-arch \
--enable-stack-protector=strong \
- --enable-stackguard-randomization \
+ --disable-crypt \
--disable-profile \
--disable-werror \
--disable-timezone-tools
- make --jobserver-style=pipe
+ make
}
package() {
cd glibc-build
- make --jobserver-style=pipe DESTDIR="$pkgdir"/usr/$_target/sys-root install
+ make DESTDIR="$pkgdir"/usr/$_target/sys-root install
#we don't want static libraries. Only keep the one that we really need.
find "$pkgdir"/usr/$_target/sys-root -name '*.a' -and -not -name libc_nonshared.a -delete