summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChrister Solskogen2023-01-06 15:32:02 +0000
committerChrister Solskogen2023-01-06 15:32:02 +0000
commitfb9e32127e092e2d8933a041c1bf6fd497effa3a (patch)
treedc4f790356eddf05932ac0addc0f704992af3d01
parentdd062e6436641c7c0719837828eb3be32d42d8b4 (diff)
downloadaur-fb9e32127e092e2d8933a041c1bf6fd497effa3a.tar.gz
workaround for make 4.4
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f0e56e1d628..8b23f19995d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aarch64-glibc
pkgdesc = GNU C Library ARM64 target
pkgver = 2.36
- pkgrel = 1
+ pkgrel = 2
url = https://www.gnu.org/software/libc/
arch = any
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 808bfc81e7e8..a414238e5082 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _arch=aarch64
_target=$_arch-unknown-linux-gnu
pkgname=$_arch-glibc
pkgver=2.36
-pkgrel=1
+pkgrel=2
_commit=be176490b818b65b5162c332eb6b581690b16e5c
pkgdesc="GNU C Library ARM64 target"
arch=(any)
@@ -33,8 +33,8 @@ build() {
#Use CFLAGS/CXXFLAGS from Arch Linux ARM
CFLAGS="-march=armv8-a -O2 -pipe -fstack-protector-strong -fno-plt -fexceptions \
- -Wformat -Werror=format-security \
- -fstack-clash-protection"
+-Wformat -Werror=format-security \
+-fstack-clash-protection"
../glibc-$pkgver/configure \
--prefix=/usr \
@@ -52,12 +52,12 @@ CFLAGS="-march=armv8-a -O2 -pipe -fstack-protector-strong -fno-plt -fexceptions
--disable-werror \
--disable-timezone-tools
- make
+ make --jobserver-style=pipe
}
package() {
cd glibc-build
- make DESTDIR="$pkgdir"/usr/$_target/sys-root install
+ make --jobserver-style=pipe DESTDIR="$pkgdir"/usr/$_target/sys-root install
#we don't want static libraries. Only keep the one that we really need.
find "$pkgdir"/usr/$_target/sys-root -name '*.a' -and -not -name libc_nonshared.a -delete