summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Derumigny2022-07-06 13:59:48 +0200
committerNicolas Derumigny2022-07-06 13:59:48 +0200
commitfdabc16aac7b519c4fc9d768f2ec07e27a9e1c88 (patch)
tree08a70d4bcd2b55dc976b333e337e08739ffbcd16
parent8a140cc637e4f3e67d930b8cb9cd81160336a3d8 (diff)
downloadaur-fdabc16aac7b519c4fc9d768f2ec07e27a9e1c88.tar.gz
Ensure cross-compiler is used
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01e267196445..bd302f8b1138 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = aarch64-linux-gnu-hwloc
pkgdesc = Portable Hardware Locality is a portable abstraction of hierarchical architectures
pkgver = 2.7.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.open-mpi.org/projects/hwloc/
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index a5b1b7236dcb..3ab37dbe0027 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ _pkgname=hwloc
_target='aarch64-linux-gnu'
pkgname=${_target}-${_pkgname}
pkgver=2.7.1
-pkgrel=1
+pkgrel=2
pkgdesc='Portable Hardware Locality is a portable abstraction of hierarchical architectures'
url='https://www.open-mpi.org/projects/hwloc/'
arch=('x86_64')
@@ -27,7 +27,7 @@ build() {
CFLAGS+=" -D__aarch64__ -march=armv8.8-a -fcf-protection=none -Wno-use-after-free"
CXXFLAGS+=" -D__aarch64__ -march=armv8.8-a -fcf-protection=none -Wno-use-after-free"
- QEMU_LD_PREFIX="/usr/${_target}/" LD_LIBRARY_PATH="/usr/${_target}/lib64" ${srcdir}/${_pkgname}-${pkgver}/configure \
+ QEMU_LD_PREFIX="/usr/${_target}/" LD_LIBRARY_PATH="/usr/${_target}/lib64" ${srcdir}/${_pkgname}-${pkgver}/configure CC="${_target}-gcc" \
--build="${_target}" \
--host="${_target}" \
--prefix=/usr/${_target} \
@@ -40,7 +40,8 @@ build() {
check() {
pushd ${_pkgname}-build
- #make check
+ # Illegal instruction as of now, will look into it later
+ # QEMU_LD_PREFIX="/usr/${_target}/" LD_LIBRARY_PATH="/usr/${_target}/lib64" make check
popd
}