summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Anderson2018-12-10 10:24:29 +0000
committerAndrew Anderson2018-12-10 10:24:29 +0000
commit14a3d2ca180757dbda978fda54d16a4f55f651f7 (patch)
treecaefc697d0e8a9d8833ae136d3ce6fa32e04009e
downloadaur-14a3d2ca180757dbda978fda54d16a4f55f651f7.tar.gz
Init
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD61
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1caeae5be79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = aarch64-linux-gnu-openblas-lapack-openmp
+ pkgdesc = Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)
+ pkgver = 0.3.3
+ pkgrel = 0
+ url = http://www.openblas.net/
+ arch = any
+ license = BSD
+ makedepends = perl
+ depends = gcc-libs
+ provides = aarch64-linux-gnu-openblas
+ provides = aarch64-linux-gnu-cblas=3.8.0
+ options = !emptydirs
+ source = OpenBLAS-0.3.3.tar.gz::https://github.com/xianyi/OpenBLAS/archive/v0.3.3.tar.gz
+ sha256sums = 49d88f4494ae780e3d7fa51769c00d982d7cdb73e696054ac3baa81d42f13bab
+
+pkgname = aarch64-linux-gnu-openblas-lapack-openmp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f82ac8a062b6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.gz
+*.xz
+/pkg
+/src
+0008-Allow-overriding-USE_COMPILER_TLS-formerly-HAS_COMPI.patch
+*.log*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a12dc054e3f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: andrewwja <aanderso [at] tcd [DOt] ie>
+# Contributor: eolianoe <eolianoe [at] gmail [DoT] com>
+# Contributor: Jiaxi Hu <sftrytry _AT_ gmail _DOT_ com>
+# Contributor: Giuseppe Borzi <gborzi _AT_ ieee _DOT_ org>
+
+pkgname=aarch64-linux-gnu-openblas-lapack-openmp
+_PkgName=OpenBLAS
+_pkgname=openblas
+pkgver=0.3.3
+# grep VERSION "${srcdir}/${_PkgName}-${pkgver}"/lapack-netlib/README.md | tail -n 1 | cut -d ' ' -f 2
+_lapackver=3.8.0
+pkgrel=0
+pkgdesc="Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)"
+arch=('any')
+url="http://www.openblas.net/"
+license=('BSD')
+depends=('gcc-libs')
+makedepends=('perl')
+provides=('aarch64-linux-gnu-openblas' "aarch64-linux-gnu-cblas=${_lapackver}")
+conflicts=()
+options=(!emptydirs)
+source=(${_PkgName}-${pkgver}.tar.gz::https://github.com/xianyi/${_PkgName}/archive/v${pkgver}.tar.gz)
+sha256sums=('49d88f4494ae780e3d7fa51769c00d982d7cdb73e696054ac3baa81d42f13bab')
+
+# Add the following line to the _config variable if you want to set the number of make jobs
+# MAKE_NB_JOBS=2 \
+
+_config="HOSTCC=gcc CC=aarch64-linux-gnu-gcc CROSS=1 TARGET=ARMV8 BINARY=64 \
+ USE_OPENMP=1 USE_THREAD=1 \
+ USE_COMPILER_TLS=0 \
+ NO_LAPACK=1 \
+ NO_LAPACKE=1"
+
+build(){
+ cd "${srcdir}/${_PkgName}-${pkgver}"
+
+ make ${_config} libs netlib shared
+}
+
+check(){
+ cd "${srcdir}/${_PkgName}-${pkgver}"
+
+ make ${_config} tests
+}
+
+package(){
+ cd "${srcdir}/${_PkgName}-${pkgver}"
+
+ make ${_config} PREFIX=/usr/aarch64-linux-gnu/ DESTDIR="${pkgdir}" install
+
+ # Install license
+ install -Dm644 LICENSE "${pkgdir}/usr/aarch64-linux-gnu/usr/share/licenses/${pkgname}/LICENSE"
+
+ # Symlink to provide cblas
+ cd "${pkgdir}/usr/aarch64-linux-gnu/usr/lib/"
+ # CBLAS
+ ln -sf libopenblas.so libcblas.so
+ ln -sf libopenblas.so libcblas.so.${_lapackver:0:1}
+ ln -sf libopenblas.so libcblas.so.${_lapackver}
+}
+# vim:set ts=2 sw=2 et: