summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlya Basin2018-03-27 14:52:01 +0300
committerIlya Basin2018-03-27 14:52:01 +0300
commitb732498c534c8dd0321739e011698abd164b0537 (patch)
tree341749562962137885dc53e614bf16e524f4ee77
downloadaur-b732498c534c8dd0321739e011698abd164b0537.tar.gz
root
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD75
2 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b90ad5a11af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Mar 27 11:51:43 UTC 2018
+pkgbase = aarch64-linux-gnu-pcre
+ pkgdesc = A library that implements Perl 5-style regular expressions
+ pkgver = 8.41
+ pkgrel = 1
+ url = http://www.pcre.org/
+ arch = any
+ license = BSD
+ depends = zlib-aarch64
+ depends = bash
+ source = https://ftp.pcre.org/pub/pcre/pcre-8.41.tar.bz2
+ source = https://ftp.pcre.org/pub/pcre/pcre-8.41.tar.bz2.sig
+ md5sums = c160d22723b1670447341b08c58981c1
+ md5sums = SKIP
+
+pkgname = aarch64-linux-gnu-pcre
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84a7ef91518d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,75 @@
+# $Id$
+# Contributor: Allan McRae <allan@archlinux.org>
+# Contributor: Eric Belanger <eric@archlinux.org>
+# Contributor: John Proctor <jproctor@prium.net>
+
+_target=aarch64-linux-gnu
+_pkgname=pcre
+pkgname=${_target}-pcre
+pkgver=8.41
+pkgrel=1
+pkgdesc='A library that implements Perl 5-style regular expressions'
+arch=('any')
+url='http://www.pcre.org/'
+license=('BSD')
+depends=(
+#'gcc-libs' 'readline'
+'zlib-aarch64'
+#'bzip2'
+'bash')
+validpgpkeys=('45F68D54BBE23FB3039B46E59766E084FB0F43D8') # Philip Hazel
+source=("https://ftp.pcre.org/pub/pcre/$_pkgname-$pkgver.tar.bz2"{,.sig})
+md5sums=('c160d22723b1670447341b08c58981c1'
+ 'SKIP')
+
+prepare() {
+ cd $_pkgname-$pkgver
+ # apply patch from the source array (should be a pacman feature)
+ local filename
+ for filename in "${source[@]}"; do
+ if [[ "$filename" =~ \.patch$ ]]; then
+ msg2 "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
+ fi
+ done
+ # avoid compiler default flags
+ sed -i "s,/usr/\(include\|lib\),/usr/${_target:?}/\1," pcre-config.in
+ :
+}
+
+build() {
+ unset CFLAGS
+ cd $_pkgname-$pkgver
+if true; then
+ ./configure \
+ --host=${_target} \
+ --prefix=/usr/${_target} \
+ --enable-unicode-properties \
+ --enable-pcre16 \
+ --enable-pcre32 \
+ --enable-jit \
+ --enable-pcregrep-libz \
+ --disable-cpp \
+# --enable-pcregrep-libbz2 \
+# --enable-pcretest-libreadline
+fi
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 LICENCE "$pkgdir/usr/${_target}/share/licenses/$_pkgname/LICENSE"
+
+ mkdir -p "$pkgdir/usr/bin"
+
+ # delete everything but the script
+ mv "$pkgdir/usr/${_target}/bin/pcre-config" "$pkgdir/usr/bin/${_target}-pcre-config"
+ rm -f "$pkgdir/usr/${_target}/bin"/*
+
+ # restore the script
+ install -Dm755 "$pkgdir/usr/bin/${_target}-pcre-config" "$pkgdir/usr/${_target}/bin/pcre-config"
+}
+
+# vim:set ts=2 sw=2 et: