summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTilmann Meyer2020-03-18 13:34:51 +0100
committerTilmann Meyer2020-03-18 13:34:51 +0100
commitb25c1aa4e9404daf4d2c9a8d0d89d470583115b6 (patch)
treecaedddb104305fad7a1595c11df6012e2ca28f8c
downloadaur-b25c1aa4e9404daf4d2c9a8d0d89d470583115b6.tar.gz
addpkg: aarch64-linux-gnu-xz
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD50
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6475cc672e1b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = aarch64-linux-gnu-xz
+ pkgdesc = Library and command line tools for XZ and LZMA compressed files (ARM64)
+ pkgver = 5.2.4
+ pkgrel = 1
+ url = https://tukaani.org/xz/
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ makedepends = aarch64-linux-gnu-configure
+ options = !buildflags
+ source = https://tukaani.org/xz/xz-5.2.4.tar.gz
+ source = https://tukaani.org/xz/xz-5.2.4.tar.gz.sig
+ validpgpkeys = 3690C240CE51B4670D30AD1C38EE757D69184620
+ sha256sums = b512f3b726d3b37b6dc4c8570e137b9311e7552e8ccbab4d39d47ce5f4177145
+ sha256sums = SKIP
+
+pkgname = aarch64-linux-gnu-xz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..586a2619484b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Tilmann Meyer <tilmann.meyer@gmx.net>
+
+_target=aarch64-linux-gnu
+
+_pkgname=xz
+pkgname=$_target-$_pkgname
+pkgver=5.2.4
+pkgrel=1
+pkgdesc='Library and command line tools for XZ and LZMA compressed files (ARM64)'
+arch=(x86_64)
+url='https://tukaani.org/xz/'
+license=(GPL LGPL)
+depends=()
+makedepends=($_target-configure)
+options=(!buildflags)
+source=(
+ https://tukaani.org/$_pkgname/$_pkgname-$pkgver.tar.gz{,.sig}
+)
+sha256sums=(
+ 'b512f3b726d3b37b6dc4c8570e137b9311e7552e8ccbab4d39d47ce5f4177145'
+ 'SKIP'
+)
+validpgpkeys=('3690C240CE51B4670D30AD1C38EE757D69184620')
+
+_srcdir=$_pkgname-$pkgver
+
+strip() {
+ ${_target}-strip "$@"
+}
+
+objcopy() {
+ ${_target}-objcopy "$@"
+}
+
+build() {
+ cd $_srcdir
+
+ mkdir -p build-$_target && pushd build-$_target
+ $_target-configure
+
+ make
+ popd
+}
+
+package() {
+ cd $_srcdir
+ pushd build-$_target
+ make DESTDIR=${pkgdir} install
+ popd
+}