summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Wild2020-09-02 01:04:37 -0400
committerAllen Wild2020-09-02 01:21:06 -0400
commit4c84f3890e71fef2f2aa5d0e6a2895f816e9a5bb (patch)
tree53a9d135356212abc598fa2824b3f35e09978438
parentae3daf800394c245cbe942e6cc8abd213f61321f (diff)
downloadaur-4c84f3890e71fef2f2aa5d0e6a2895f816e9a5bb.tar.gz
update to 1.2.21-1
* new maintainer * update url to new website * install wrapper as aarch64-linux-musl-gcc rather than aarch64-linux-musl-gnu-gcc * remove obselete --sysroot configure option * add gitignore * misc style cleanup
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD35
3 files changed, 31 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1049ddc6d99..9aeb6241ee1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = aarch64-linux-musl
pkgdesc = Lightweight implementation of C standard library
- pkgver = 1.1.17
+ pkgver = 1.2.1
pkgrel = 1
- url = http://www.musl-libc.org/
+ url = https://musl.libc.org
arch = i686
arch = x86_64
license = MIT
@@ -11,10 +11,10 @@ pkgbase = aarch64-linux-musl
options = staticlibs
options = !buildflags
options = !strip
- source = https://www.musl-libc.org/releases/musl-1.1.17.tar.gz
- source = https://www.musl-libc.org/releases/musl-1.1.17.tar.gz.asc
+ source = https://musl.libc.org/releases/musl-1.2.1.tar.gz
+ source = https://musl.libc.org/releases/musl-1.2.1.tar.gz.asc
validpgpkeys = 836489290BB6B70F99FFDA0556BCDB593020450F
- sha256sums = c8aa51c747a600704bed169340bf3e03742ceee027ea0051dd4b6cc3c5f51464
+ sha256sums = 68af6e18539f646f9c41a3a2bb25be4a5cfa5a8f65f0bb647fd2bbfdf877e84b
sha256sums = SKIP
pkgname = aarch64-linux-musl
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0b8af5350c8f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/src/
+/pkg/
+
+*.pkg.tar*
+musl-*.tar.gz
+musl-*.tar.gz.asc
diff --git a/PKGBUILD b/PKGBUILD
index 980ed85a10a0..de46fe8ba907 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,49 @@
-# Maintainer: Riley Trautman <asonix.dev@gmail.com>
+# Maintainer: Allen Wild <allenwild93@gmail.com>
+# Contributor: Riley Trautman <asonix.dev@gmail.com>
-_pkgname=musl
-_target=aarch64-linux-gnu
pkgname=aarch64-linux-musl
-pkgver=1.1.17
+pkgver=1.2.1
pkgrel=1
pkgdesc='Lightweight implementation of C standard library'
arch=('i686' 'x86_64')
-url='http://www.musl-libc.org/'
+url='https://musl.libc.org'
license=('MIT')
options=('staticlibs' '!buildflags' '!strip')
makedepends=('aarch64-linux-gnu-binutils' 'aarch64-linux-gnu-gcc')
validpgpkeys=('836489290BB6B70F99FFDA0556BCDB593020450F')
-source=(https://www.musl-libc.org/releases/musl-$pkgver.tar.gz{,.asc})
-sha256sums=('c8aa51c747a600704bed169340bf3e03742ceee027ea0051dd4b6cc3c5f51464'
+source=(https://musl.libc.org/releases/musl-1.2.1.tar.gz{,.asc})
+sha256sums=('68af6e18539f646f9c41a3a2bb25be4a5cfa5a8f65f0bb647fd2bbfdf877e84b'
'SKIP')
+
+_target=aarch64-linux-gnu
_sysroot=/usr/$_target/lib/musl
build() {
- cd $_pkgname-$pkgver
- ./configure --prefix=$_sysroot --sysroot=$_sysroot \
- --bindir=/usr/bin --target=$_target \
- --enable-wrapper=all
+ cd musl-$pkgver
+ ./configure --prefix=$_sysroot \
+ --exec-prefix=/usr \
+ --target=$_target \
+ --enable-wrapper=all
make
}
package() {
- cd $_pkgname-$pkgver
+ cd musl-$pkgver
make DESTDIR="$pkgdir" install
- install -dm755 "$pkgdir$_sysroot"
- mv "$pkgdir"/lib/ld-musl*.so* "$pkgdir$_sysroot"/lib
+ # configure syslibdir with /lib for PT_INTERP compat, but install to /usr/lib
+ mv "$pkgdir"/lib/ld-musl*.so* "$pkgdir$_sysroot"/lib/
rmdir "$pkgdir"/lib
pushd "$pkgdir"/usr/bin
+ local _bin
for _bin in *; do
- mv "$_bin" $_target-$_bin
+ mv "$_bin" "${_target%-gnu}-$_bin"
done
popd
install -Dm0644 README "$pkgdir"/usr/share/doc/$pkgname/README
install -Dm0644 COPYRIGHT "$pkgdir"/usr/share/licenses/$pkgname/COPYRIGHT
}
+
+# vim: et ts=2 sts=2 sw=2