summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorErnestas Kulik2017-04-14 16:01:01 +0300
committerErnestas Kulik2017-04-14 16:17:25 +0300
commit24559ae2042e651f0ea3019b0e148261272e85aa (patch)
tree856cee8576d6322cb629c74d965ab67d0193d514
downloadaur-24559ae2042e651f0ea3019b0e148261272e85aa.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD52
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4603c4de493
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Apr 14 13:17:13 UTC 2017
+pkgbase = aarch64-none-elf-binutils
+ pkgdesc = A set of programs to assemble and manipulate binary and object files.
+ pkgver = 2.28
+ pkgrel = 1
+ url = https://www.gnu.org/software/binutils/
+ arch = x86_64
+ license = GPL3
+ depends = glibc
+ depends = zlib
+ options = !buildflags
+ source = https://ftp.gnu.org/gnu/binutils/binutils-2.28.tar.bz2
+ source = https://ftp.gnu.org/gnu/binutils/binutils-2.28.tar.bz2.sig
+ sha1sums = f8b033731f6baa437d429c60e2623570f1ef9d6b
+ sha1sums = SKIP
+
+pkgname = aarch64-none-elf-binutils
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d6357dc194a6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/aarch64-none-elf-binutils-*.pkg.tar.xz
+/binutils-*.tar.bz2*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..206512f320d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Ernestas Kulik <ernestas DOT kulik AT gmail DOT com>
+
+_target=aarch64-none-elf
+
+pkgname=${_target}-binutils
+pkgver=2.28
+pkgrel=1
+pkgdesc='A set of programs to assemble and manipulate binary and object files.'
+url='https://www.gnu.org/software/binutils/'
+license=('GPL3')
+source=("https://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.bz2"
+ "https://ftp.gnu.org/gnu/binutils/binutils-${pkgver}.tar.bz2.sig")
+validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93') # Tristan Gingold <gingold@adacore.com>
+sha1sums=('f8b033731f6baa437d429c60e2623570f1ef9d6b'
+ 'SKIP')
+arch=('x86_64')
+depends=('glibc' 'zlib')
+options=('!buildflags')
+
+build() {
+ cd binutils-$pkgver
+
+ ./configure \
+ --disable-nls \
+ --disable-werror \
+ --enable-deterministic-archives \
+ --enable-gold \
+ --enable-ld=default \
+ --enable-plugins \
+ --prefix=/usr \
+ --target=$_target \
+ --with-gnu-as \
+ --with-gnu-ld \
+ --with-sysroot=/usr/$_target
+
+ make
+}
+
+check() {
+ cd binutils-$pkgver
+
+ make check
+}
+
+package() {
+ cd binutils-$pkgver
+
+ make DESTDIR="$pkgdir" install
+
+ rm "$pkgdir"/usr/share/man/man1/${_target}-{dlltool,nlmconv,windmc,windres}.1
+ rm -r "$pkgdir"/usr/share/info
+}