summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormisson200002017-09-28 15:36:21 -0700
committermisson200002017-09-28 15:36:21 -0700
commit7038ce78fc65a9190286fb5d45edf2d23e5fe2a9 (patch)
tree11b0f9f96dadc425c745fb6a38fe23481fcbe062
downloadaur-7038ce78fc65a9190286fb5d45edf2d23e5fe2a9.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD51
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22755223cecd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = aarch64-none-elf-gdb
+ pkgdesc = The GNU Debugger for the ARM64 target
+ pkgver = 8.0.1
+ pkgrel = 1
+ url = http://www.gnu.org/software/gdb/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = xz
+ depends = ncurses
+ depends = expat
+ depends = python
+ depends = guile2.0
+ depends = gdb-common
+ options = !emptydirs
+ source = ftp://ftp.gnu.org/gnu/gdb/gdb-8.0.1.tar.xz
+ source = ftp://ftp.gnu.org/gnu/gdb/gdb-8.0.1.tar.xz.sig
+ validpgpkeys = F40ADB902B24264AA42E50BF92EDB04BFF325CF3
+ sha256sums = 3dbd5f93e36ba2815ad0efab030dcd0c7b211d7b353a40a53f4c02d7d56295e3
+ sha256sums = SKIP
+
+pkgname = aarch64-none-elf-gdb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9af5b777ded
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id$
+
+_target=aarch64-none-elf
+pkgname=$_target-gdb
+pkgver=8.0.1
+pkgrel=1
+pkgdesc='The GNU Debugger for the ARM64 target'
+arch=(i686 x86_64)
+url='http://www.gnu.org/software/gdb/'
+license=(GPL3)
+depends=(xz ncurses expat python guile2.0 gdb-common)
+options=(!emptydirs)
+source=(ftp://ftp.gnu.org/gnu/gdb/gdb-$pkgver.tar.xz{,.sig})
+validpgpkeys=('F40ADB902B24264AA42E50BF92EDB04BFF325CF3') # Joel Brobecker
+sha256sums=('3dbd5f93e36ba2815ad0efab030dcd0c7b211d7b353a40a53f4c02d7d56295e3'
+ 'SKIP')
+
+prepare() {
+ cd gdb-$pkgver
+ sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
+}
+
+build() {
+ cd gdb-$pkgver
+
+ ./configure \
+ --target=$_target \
+ --prefix=/usr \
+ --enable-languages=c,c++ \
+ --disable-multilib \
+ --enable-interwork \
+ --with-system-readline \
+ --disable-nls \
+ --with-python=/usr/bin/python3 \
+ --with-guile=guile-2.0 \
+ --with-system-gdbinit=/etc/gdb/gdbinit
+
+ make
+}
+
+package() {
+ cd gdb-$pkgver
+
+ make DESTDIR="$pkgdir" install
+
+ # Following files conflict with 'gdb' package
+ rm -r "$pkgdir"/usr/share/info
+ rm -r "$pkgdir"/usr/share/gdb
+ rm -r "$pkgdir"/usr/include/gdb
+ rm -r "$pkgdir"/usr/share/man/man5
+}