summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Ericson2015-07-07 00:08:59 -0300
committerAndré Ericson2015-07-07 00:08:59 -0300
commit2e21959b2248d3e8ded79995fca836449b7d2790 (patch)
treeb27dc3b7d5b6339a5d7fcc4bea2325630ce6ab42
downloadaur-2e21959b2248d3e8ded79995fca836449b7d2790.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD35
-rw-r--r--aarchup.install15
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e3d37689e58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = aarchup
+ pkgdesc = Fork of archup a small and lightweight update-notifier for archlinux.
+ pkgver = 1.7.3
+ pkgrel = 2
+ url = https://github.com/aericson/aarchup
+ install = aarchup.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libnotify
+ makedepends = autoconf
+ makedepends = gzip
+ depends = pacman
+ depends = libnotify
+ depends = gtk2
+ optdepends = cower: AUR support(--aur)
+ backup = etc/systemd/system/aarchup.timer
+ source = https://github.com/aericson/aarchup/archive/1.7.3.zip
+ md5sums = 204df2d8b83ce76c79b88ba4b10f370e
+
+pkgname = aarchup
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c36761532c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Rorschach <r0rschach@lavabit.com>
+# Contributor: Andrew Kravchuk <awkravchuk@gmail.com>
+# Contributor: aericson <de.ericson@gmail.com>
+
+pkgname=aarchup
+pkgver=1.7.3
+pkgrel=2
+pkgdesc="Fork of archup a small and lightweight update-notifier for archlinux."
+url="https://github.com/aericson/aarchup"
+arch=('i686' 'x86_64')
+license="GPL"
+depends=('pacman' 'libnotify' 'gtk2')
+makedepends=('libnotify' 'autoconf' 'gzip')
+source=("https://github.com/aericson/aarchup/archive/$pkgver.zip")
+md5sums=('204df2d8b83ce76c79b88ba4b10f370e')
+backup=('etc/systemd/system/aarchup.timer')
+optdepends=('cower: AUR support(--aur)')
+install='aarchup.install'
+
+prepare() {
+ mv -v $pkgname-$pkgver/src/* $pkgname-$pkgver/
+ rmdir $pkgname-$pkgver/src
+}
+
+build() {
+ cd $pkgname-$pkgver/
+ autoconf || return 1
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd $pkgname-$pkgver/
+ make DESTDIR="$pkgdir/" install || return 1
+}
diff --git a/aarchup.install b/aarchup.install
new file mode 100644
index 000000000000..0085d4ff41de
--- /dev/null
+++ b/aarchup.install
@@ -0,0 +1,15 @@
+post_upgrade() {
+ cat << EOF
+ Crontab is no longer supported. The prefered method is still with --loop-time.
+ Alternatively you can use systemd timer included in the package. Please see man aarchup.
+ If you wish to use the systemd timer you can set the time frequency on the file /etc/systemd/system/aarchup.timer
+EOF
+}
+
+post_install() {
+ cat <<EOF
+ Please check man pages for installation instructions.
+ If you have any problems or would like to request a feature,
+ check https://bbs.archlinux.org/viewtopic.php?id=119129
+EOF
+}