summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonidas Spyropoulos2018-07-05 00:21:38 +0100
committerLeonidas Spyropoulos2018-07-05 00:21:38 +0100
commit628b0ba90c2c08c7b45ad8af492fe9651ac154ba (patch)
treeab1e8a27a99b9804c94bb024132ad838d33699b8
parentbbf7f99ed6fd709aeb652f190a3a72d9c9b34c4a (diff)
downloadaur-628b0ba90c2c08c7b45ad8af492fe9651ac154ba.tar.gz
upgpkg: aarchup 1.8.2-1
upstream release
-rw-r--r--.SRCINFO13
-rw-r--r--0001-aarchup.c-switch-to-auracle-sync.patch68
-rw-r--r--PKGBUILD19
3 files changed, 12 insertions, 88 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5962ce4becb..6636e620af67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = aarchup
pkgdesc = Fork of archup a small and lightweight update-notifier for archlinux.
- pkgver = 1.8.1
- pkgrel = 3
- url = https://github.com/aericson/aarchup
+ pkgver = 1.8.2
+ pkgrel = 1
+ url = https://github.com/inglor/aarchup
install = aarchup.install
arch = i686
arch = x86_64
@@ -14,11 +14,8 @@ pkgbase = aarchup
depends = gtk2
optdepends = auracle: AUR support(--aur)
provides = aarchup
- backup = etc/systemd/system/aarchup.timer
- source = aarchup-1.8.1.zip::https://github.com/aericson/aarchup/archive/1.8.1.zip
- source = 0001-aarchup.c-switch-to-auracle-sync.patch
- sha256sums = 9d96df312502ac61379678a7297dd1c40b045709054c66691e3680fa389096fe
- sha256sums = e1d0e0cacabd2f13be23a570320fbad37619d6f752e524f94e791871c7ca28b6
+ source = aarchup-1.8.2.zip::https://github.com/inglor/aarchup/archive/1.8.2.zip
+ sha256sums = 0ff8834846c1162cfbfd66e24dc02cbf0a05b0f767db2345504a516025a438d4
pkgname = aarchup
diff --git a/0001-aarchup.c-switch-to-auracle-sync.patch b/0001-aarchup.c-switch-to-auracle-sync.patch
deleted file mode 100644
index 724bee138f93..000000000000
--- a/0001-aarchup.c-switch-to-auracle-sync.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From 658412ac9603bfbf1a49c7c6e5cf23becb79dc38 Mon Sep 17 00:00:00 2001
-From: Alad Wenter <alad@mailbox.org>
-Date: Fri, 9 Feb 2018 02:26:20 +0100
-Subject: [PATCH] aarchup.c: switch to "auracle sync"
-
-More efficient replacement of cower by the same author.
----
- aarchup.c | 18 ++++++++----------
- 1 file changed, 8 insertions(+), 10 deletions(-)
-
-diff --git a/aarchup.c b/aarchup.c
-index e3840eb..bbce913 100644
---- a/aarchup.c
-+++ b/aarchup.c
-@@ -31,15 +31,13 @@
- #define VERSION_NUMBER "1.8.1"
-
-
--/* Parse cower -u output.
-- * Format: ":: package_name version -> new_version" */
-+/* Parse auracle sync output.
-+ * Format: "package_name version -> new_version" */
- void parse(char *line){
- int i, j;
- int llen = strlen(line);
-- /* Find first space */
-- for(i=0;!isspace(line[i]) && i < llen; ++i);
- /* Copy package_name */
-- for(j=0, ++i;!isspace(line[i]) && i < llen;++j, ++i)
-+ for(j=0, i=0;!isspace(line[i]) && i < llen;++j, ++i)
- line[j] = line[i];
- i = llen - 1;
- line[j++] = ' ';
-@@ -236,7 +234,7 @@ int print_help(char *name)
- printf(" For more information on it check man.\n");
- printf(" --help Prints this help.\n");
- printf(" --version Shows the version.\n");
-- printf(" --aur Check aur for new packages too. Will need cower installed.\n");
-+ printf(" --aur Check aur for new packages too. Will need auracle installed.\n");
- printf(" --debug|-d Print debug info.\n");
- printf(" --ftimeout|-f [value] Program will manually enforce timeout for closing notification.\n");
- printf(" Do NOT use with --timeout, if --timeout works or without --loop-time [value].\n");
-@@ -503,7 +501,7 @@ int main(int argc, char **argv)
- /* Those are needed by libnotify. */
- char *name = "New Updates";
- char *category = "update";
-- char *cower = "cower -u";
-+ char *auracle = "auracle sync";
- NotifyNotification *my_notify = NULL;
-
- /* Those are needed for the output. */
-@@ -574,10 +572,10 @@ int main(int argc, char **argv)
- if(aur && i < max_number_out){
- if(debug)
- printf("DEBUG(info): aur is on, checking for updates in aur\n");
-- /* call cower */
-+ /* call auracle */
- if(debug)
-- printf("DEBUG(info): running command: %s\n", cower);
-- pac_out = popen(cower, "r");
-+ printf("DEBUG(info): running command: %s\n", auracle);
-+ pac_out = popen(auracle, "r");
- if(ignore_pkg_flag)
- IgnorePkg = get_ignore_pkgs(&ign_pkg_size,debug);
-
---
-2.16.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 8a1b5476ca56..f3c43b3d6562 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,31 @@
# Maintainer: ValHue <vhuelamo at gmail dot com>
-# Maintainer: artafinde <artafinde at gmail dot com>
+# Maintainer: Leonidas Spyropoulos <artafinde at gmail dot com>
# Contributor: aericson <de.ericson at gmail dot com>
# Contributor: Rorschach <r0rschach at lavabit dot com>
# Contributor: Andrew Kravchuk <awkravchuk at gmail dot com>
#
pkgname="aarchup"
-pkgver=1.8.1
-pkgrel=3
+pkgver=1.8.2
+pkgrel=1
pkgdesc="Fork of archup a small and lightweight update-notifier for archlinux."
-url="https://github.com/aericson/aarchup"
+url="https://github.com/inglor/aarchup"
arch=('i686' 'x86_64')
license=('GPL3')
provides=("${pkgname}")
depends=('libnotify' 'gtk2')
makedepends=('libnotify' 'autoconf' 'gzip')
-backup=('etc/systemd/system/aarchup.timer')
optdepends=('auracle: AUR support(--aur)')
install='aarchup.install'
-source=("${pkgname}-${pkgver}.zip::${url}/archive/${pkgver}.zip"
- '0001-aarchup.c-switch-to-auracle-sync.patch'
-)
-sha256sums=('9d96df312502ac61379678a7297dd1c40b045709054c66691e3680fa389096fe'
- 'e1d0e0cacabd2f13be23a570320fbad37619d6f752e524f94e791871c7ca28b6')
+source=("${pkgname}-${pkgver}.zip::${url}/archive/${pkgver}.zip")
+sha256sums=('0ff8834846c1162cfbfd66e24dc02cbf0a05b0f767db2345504a516025a438d4')
prepare() {
- mv -v "${pkgname}-${pkgver}"/src/* "${pkgname}-${pkgver}"
+ mv "${pkgname}-${pkgver}"/src/* "${pkgname}-${pkgver}"
rmdir "${pkgname}-${pkgver}"/src
}
build() {
cd "${pkgname}-${pkgver}"
- patch -p1 < ../0001-aarchup.c-switch-to-auracle-sync.patch
autoconf
./configure --prefix=/usr
make