summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-10-25 13:11:17 +0100
committerhaawda2020-10-25 13:11:17 +0100
commit0999bcbc90ffac3654a6d5b90d7d9ba48a74c8bd (patch)
tree0002e7690ef4191bd774c20cd6838d60518db67a
parenta488368868e3cbe8c218b22bc619de9097dab3a2 (diff)
downloadaur-0999bcbc90ffac3654a6d5b90d7d9ba48a74c8bd.tar.gz
complete rewrite: different repo, meson build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f57475999b4..2266b5ca3119 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = aarchup-git
pkgdesc = Fork of archup a small and lightweight update-notifier for archlinux.
- pkgver = 2.1.0.r1.ga8e4cf5
+ pkgver = 2.1.5
pkgrel = 1
url = https://github.com/inglor/aarchup
install = aarchup.install
@@ -15,7 +15,7 @@ pkgbase = aarchup-git
optdepends = auracle: AUR support(--aur)
provides = aarchup
conflicts = aarchup
- source = git+https://github.com/inglor/aarchup.git
+ source = git+https://gitlab.com/artafinde/aarchup.git
md5sums = SKIP
pkgname = aarchup-git
diff --git a/PKGBUILD b/PKGBUILD
index aed7b24ae7af..2451eddc5614 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=aarchup-git
-pkgver=2.1.0.r1.ga8e4cf5
+pkgver=2.1.5
pkgrel=1
pkgdesc="Fork of archup a small and lightweight update-notifier for archlinux."
url="https://github.com/inglor/aarchup"
@@ -12,7 +12,7 @@ arch=('i686' 'x86_64')
license=('GPL')
depends=('libnotify' 'gtk2')
makedepends=('git' 'cmake' 'ninja')
-source=("git+https://github.com/inglor/aarchup.git")
+source=("git+https://gitlab.com/artafinde/aarchup.git")
md5sums=('SKIP')
conflicts=('aarchup')
provides=('aarchup')
@@ -25,14 +25,12 @@ pkgver() {
}
build() {
- cd ${pkgname%-git}/src
- cmake .. -G Ninja \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr
- ninja all
+ cd ${pkgname%-git}
+ meson --prefix=/usr --buildtype=plain . build
+ meson compile -C build
}
package() {
- cd ${pkgname%-git}/src
- DESTDIR="$pkgdir/" ninja install
+ cd ${pkgname%-git}
+ DESTDIR="$pkgdir/" ninja install -C build
}