summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-04-02 19:35:26 +0200
committerhaawda2018-04-02 19:35:26 +0200
commit3cc6afdaa64f74fd790a8a8453dccde973ba6028 (patch)
tree1bc4588c9e05fc6ddc29bb732ade96c2b17da595
downloadaur-3cc6afdaa64f74fd790a8a8453dccde973ba6028.tar.gz
initial upload
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD38
-rw-r--r--aarchup.install19
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc0d7240d023
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Mon Apr 2 17:35:18 UTC 2018
+pkgbase = aarchup-git
+ pkgdesc = Fork of archup a small and lightweight update-notifier for archlinux.
+ pkgver = 1.8.1.5.g32fe8c7
+ pkgrel = 1
+ url = https://github.com/aericson/aarchup
+ install = aarchup.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = libnotify
+ depends = gtk2
+ optdepends = auracle: AUR support(--aur)
+ provides = aarchup
+ conflicts = aarchup
+ backup = usr/lib/systemd/system/aarchup.timer
+ source = git+https://github.com/stefanhusmann/aarchup.git
+ md5sums = SKIP
+
+pkgname = aarchup-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..419ec5bcd621
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: Rorschach <r0rschach@lavabit.com>
+# Contributor: Andrew Kravchuk <awkravchuk@gmail.com>
+# Contributor: aericson <de.ericson@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=aarchup-git
+pkgver=1.8.1.5.g32fe8c7
+pkgrel=1
+pkgdesc="Fork of archup a small and lightweight update-notifier for archlinux."
+url="https://github.com/aericson/aarchup"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('libnotify' 'gtk2')
+makedepends=('git')
+source=("git+https://github.com/stefanhusmann/aarchup.git")
+md5sums=('SKIP')
+backup=('usr/lib/systemd/system/aarchup.timer')
+conflicts=('aarchup')
+provides=('aarchup')
+optdepends=('auracle: AUR support(--aur)')
+install=aarchup.install
+
+pkgver() {
+ cd ${pkgname%-git}
+ git describe --tags | sed 's+-+.+g'
+}
+
+build() {
+ cd ${pkgname%-git}/src
+ autoconf
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname%-git}/src
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/aarchup.install b/aarchup.install
new file mode 100644
index 000000000000..2eafe0eb4a84
--- /dev/null
+++ b/aarchup.install
@@ -0,0 +1,19 @@
+post_upgrade() {
+ cat << EOF
+ To avoid problems with partial upgrades (http://gist.io/5660494) we no longer
+ use the combination of pacman -Sy/-Qu to check for updates. We now use checkupdates.
+
+ As a result of this --ignore-disconnect was removed. Please remove it from your configurations, if you were using it.
+
+ If you were using --command|-c, note that the command has to check for updates now
+ since we no longer call pacman -Sy.
+EOF
+}
+
+post_install() {
+ cat <<EOF
+ Please check man pages for installation instructions.
+ If you have any problems or would like to request a feature,
+ check https://bbs.archlinux.org/viewtopic.php?id=119129
+EOF
+}