summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorParker Reed2019-03-07 21:31:50 -0500
committerParker Reed2019-03-07 21:31:50 -0500
commit3c68b7705b596b1bf04becde15174c93814350fa (patch)
tree46cd7cd9a1190ea47664a1f8d66716c82ff135b0
parent84c71d1a340f8f1c3716504d39056328e8ced08c (diff)
downloadaur-3c68b7705b596b1bf04becde15174c93814350fa.tar.gz
Build fix, thanks to urizen
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
-rw-r--r--promise.patch11
3 files changed, 24 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0652e781a037..b00eed9170f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,6 +15,8 @@ pkgbase = aasdk-git
provides = aasdk
conflicts = aasdk
source = aasdk-git::git+https://github.com/f1xpl/aasdk.git#branch=master
+ source = promise.patch
+ md5sums = SKIP
md5sums = SKIP
pkgname = aasdk-git
diff --git a/PKGBUILD b/PKGBUILD
index 1e3f4bc7717f..eb4a932db658 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,14 +11,23 @@ provides=($_pkgname)
conflicts=($_pkgname)
depends=('libusb' 'protobuf' 'openssl' 'boost-libs')
makedepends=('cmake' 'boost' 'git')
-source=("$pkgname::git+https://github.com/f1xpl/aasdk.git#branch=master")
-md5sums=('SKIP')
+source=(
+ "$pkgname::git+https://github.com/f1xpl/aasdk.git#branch=master"
+ promise.patch
+)
+md5sums=('SKIP'
+ 'SKIP')
pkgver() {
cd $pkgname
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd $pkgname
+ patch --forward --strip=1 --input="${srcdir}/promise.patch"
+}
+
build() {
cd $pkgname
mkdir -p aasdk_build
diff --git a/promise.patch b/promise.patch
new file mode 100644
index 000000000000..308b2e061462
--- /dev/null
+++ b/promise.patch
@@ -0,0 +1,11 @@
+diff --git a/include/f1x/aasdk/IO/Promise.hpp b/include/f1x/aasdk/IO/Promise.hpp
+index 9f5e222..646b258 100644
+--- a/include/f1x/aasdk/IO/Promise.hpp
++++ b/include/f1x/aasdk/IO/Promise.hpp
+@@ -20,6 +20,7 @@
+
+ #include <functional>
+ #include <boost/asio.hpp>
++#include <boost/core/noncopyable.hpp>
+ #include <f1x/aasdk/Error/Error.hpp>
+ #include <f1x/aasdk/IO/IOContextWrapper.hpp>